๐Ÿ†•[add-on] HassOS SSH port 22222 Configurator

this method worked after so many tries

Tell meโ€ฆ would it be helpful if I add a check box boolean Disregard entered key and generate a new one

This checkbox would perform the following actions:

  1. Generate a key
  2. Store the key in the /config/addon-22222/ folder

The general flow would be modified to:

  1. If key exists use it otherwise use entered key.
  2. Notify user this is occurring via logs.
  3. Upon completion, provide instructions on where to find the key, how to delete the key, and how to log in from Terminal app.

To make this work do I have to do a full hardware poweroff or should a proper host reboot be enough? I try to SSH from localhost SSH to the localport 22222 and I have tried also to generate a new key but to no avail. Just wondering if the problem is that I need to poweroff - but I have no physical access.

Yes please.
I run HAOS in a VM on TrueNAS Scale, so this will make it easier.

Question too please; does this addon provide a way to mount a remote Samba share to the underlying OS so it can be used by other addons? My use cases are Logitech Media Server playing music from TrueNAS and AA CCTV addon saving video to a share.

Full reboot. It can be done from the WebUI in HAOS.

No but you can find my other addon โœ”๏ธ๐ŸƒRun On Startup.d

I am trying this and after installation, my config tab says โ€œThis add-on has no configuration.โ€

Awesome plugin, I managed to get in after ensuring I used the correct putty-gen key. Thanks for this!

If I wanted to edit a core plugin (copying to custom_component does not work)โ€ฆ where would the core files be located? โ€ฆ Iโ€™ve done the following,

#docker exec -it homeassistant /bin/bash
cd /usr/local/lib/python3.10/site-packages/

however I cannot findโ€ฆ homeassistant/components/

Would be nice to have this either included or a note put on the instructions that you can do this manually :slight_smile:

That said, thanks for this add-on. it saved me a ton of time.

Thank you for this one, it finally got me in.
It does turn out that the โ€œunplug the power cableโ€ physical power off and on is really required.
The supervisorโ€™s โ€œrestart hostโ€ is not enough, even if you do it twice.

I am using Home Assistant Yellow (CM4 with NVMe as an only storage).

Is it supported configuration?

Add-on logs:

/dev folder contains:
(sry, cannot insert multiple images as new user)

There is โ€œnvme0n1p1โ€ entity, but probably not used for this purpose?


It probably is able to be supported. Iโ€™d need to see the file structure. If you or someone else can mount the p1 partition, then ls the root of it, I may be able to support it.

I would be glad to help - not sure if I have enough experiences, unfortunatelyโ€ฆ

I am able to connect using standard ssh, but I cannot mount the p1 unit (basically cannot mount anything)

[core-ssh /]$ mkdir /tmp/nvme
[core-ssh /]$ mount -t ext4 /dev/nvme0n1p1 /tmp/nvme
mount: mounting /dev/nvme0n1p1 on /tmp/nvme failed: Permission denied

other folders seems to be mounted from nvme0n1p8:

Try the ssh & web terminal addon.

Disable protection mode.

Try the mount.

here is the root of p1 on a Yellow:

bash-5.1# ls -l
total 2850
-rwxr-xr-x    1 root     root         55143 Jun 17 01:54 bcm2711-rpi-cm4-ha-yellow.dtb
-rwxr-xr-x    1 root     root          3049 Jun 17 01:54 boot.scr
-rwxr-xr-x    1 root     root            59 Jun 17 01:54 cmdline.txt
-rwxr-xr-x    1 root     root           864 Jun 17 01:54 config.txt
-rwxr-xr-x    1 root     root          5399 Jun 17 01:54 fixup4.dat
drwxr-xr-x    2 root     root         24576 Jun 17 01:54 overlays
-rwxr-xr-x    1 root     root       2251392 Jun 17 01:54 start4.elf
-rwxr-xr-x    1 root     root        569376 Jun 17 01:54 u-boot.bin

I was able to mount it after getting into the supervisor container from the SSH add-on container

docker exec -it hassio_supervisor bash
mount /dev/mmcblk0p1 /mnt

Hi this is my log file does it look ok as I still canโ€™t login

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
no vda1 config found
creating authorized keys in sda1 !
no sdb1 config found
no mmcblk0p1 config found
no mmcblk1p1 config found
no nvme0n1p1 config found
This Configurator did itโ€™s job. Perform a hard-power-off now. This configurator only works once and is no longer needed.

Not all keys are compatible. Try creating a new one. Also make sure you rebooted the hardware.

How Can you use 2 SSH keys for 2 machines? is that possible?

Of course.

Iโ€™ve never tried it, but I think you could just use a \n delimiter character between each key