Add-on Issue


I’m following the tutorial posted here but i’m hitting a few issues and would appreciate some help:

The add-on installs ok and launches. I’m presuming that the python3 call to start the HTTP daemon is also working because without the command in the script the add-on doesn’t remain in a running state.

However, the issue is that the HTTP daemon doesn’t seem to listen. I went into the terminal and tried using a netstat command but I couldn’t see any process listening on port 8000 as specified. I also tried finding the process using a ps -ef | grep command but that also failed ot show anything up.

Is anyone able to suggest what the issue might be or help me to write some code that I might use to debug the issue?

I’ve worked as a coder before doing C# and C++ but it was a while ago and i’m a bit rusty. From what I can make out the .sh file we’re building in the sample is actually a shell script so i’m hoping that once i’ve got the basics out of the way I can start to do more with it.

Thanks in advance for any help offered.


@frenck is probably the man to answer :slight_smile:

Thanks @nickrout. Hopefully he might comment and help out at some point. :slight_smile:

Hop on Discord and let’s figure it out!

Thanks @frenck. I’ll try to jump on DIscord this evening if you’re likely to be around? Hard for me to do much from here at work. :slight_smile: