Add-on request : wmbusmeter

No its a booster cable but have it Working now. It was my config that was wrong

Has anyone successfully used this add-on together with the device RTL2832U ? To get data from a MultiCal21

There is a fork of the wmbusmeter project that allows the use of this type of device, I think, but it’s not available as an add-on.

Can I ask what you changed from default config? I don’t receive any telegram in my log from meter. It have recognized my USB dongle but only got my Mozilla and my phone listed in the log. Can’t see any meters.

My device is 5-6 meters from the meter and as I read the range should be like 500 meters on the im871a-usb.

In my case “helped” to remove the default example meter, then after restart I got message No meters configured. Printing id:s of all telegrams heard! followed by all the received telegrams. Unfortunately all my meters are encrypted.

1 Like

Is the Home Assistant integration for this still available? The link above leads to error 404

Hello all,

the wmbusmeter repo you will find here: GitHub - wmbusmeters/wmbusmeters-ha-addon: To become the new public ha-addon repository for wmbusmeters.

It works like a charm! You can choose between the stable and the edge version.
i personaly prefer the stable version. But if you need it, fixes and enhancemnets will go into the edge version a litle bit faster.

BR

1 Like

Thanks. I had found that shortly after asking 🫣
Now I just have to hope that I will get the access key to my water meter once it has been installed in two weeks🤞

I’m not sure mine is working. I have a Sensostar T + the dongle recommend by @hubikj above ( iM871A-USB - Wireless M-Bus USB-adapter 868 MHz ) and this is how my log on looks like:

How do I know if it is working? It’s not showing on my MQTT devices.
I’m confused how to proceed from here.

@hubikj mentioned “I was lucky there is no encryption on my meters” - how do I know if mine are encrypted?

If you did not configure any meters, then you have to keep it running like this for some time (preferably during work hours - not all meters broadcast all the time). Eventually, the log will show the meters that broadcasted a measurement. Once that happens, you have to take the details from that log and configure a meter with that info. If the telegrams are encrypted, you will not be able to get the measurements without the key (you always need a key, mine just happens to be 00000000000000000000000000000000)

1 Like

Hi guys,
I basically copied the setup from @hubikj (thanks man!), including the dongle type, defined the meters in the wmbusmeters addon but I am still detecting weird (IMHO) behaviour.
see here:

I must add I have zero experience with setting up MQTT (all my other integrations do not need it).

I got an answers from our water supplier and they told me I can request the AES key when the meter has been installed. That’s great news, now I can go and order a USB Wmbus stick and get HA ready…:+1:

1 Like

My new water meter was installed this morning. The addon can see it and get data from it (though currently still showing “encrypted” since I haven’t received the key yet) but I have some trouble with the “id” setting in the addon

I can see an ID in the logs, essentially the sender of the “Telegram” but if I select that then I always get the error that it’s not a valid ID. The same happens with pretty much anything I put in that field.

What am I missing?

Edit: Never mind. I got the AES key and it now works without a hitch.

What can I do, when I can not found driver for my wMBUS modul ?

I have Honeywell MERLIN 868 wMBUS MODULE with M871A-USB - Wireless M-Bus USB-adapter 868 MHz.

I tried analyze telegram but without results.

I have the same problem - can I ask what was your solution?

Were you able to use the RTU2832U device to work with wmbusmeter?

I have not dived into it. Eager to hear if anyone else have.

Got it to work using this device definition:

Now I just have to get the encryption key to read the contents of the telegrams from the flow meter.

If you have a kamstrup meter, you might be able to retrieve the kem file using this procedure:

Thanks for the tip, but I already tried that. When registering the device (the water flow meter) on the Encryption Key Service page, I get the following error message: The device does not have the right availability level.

I’ve asked the utility for the key, but I have so far not got an answer.