Add-on Store is broken 'Failed to fetch add-on info'


Yesterday I tried to install ESPhome, but after I input the URL the Add-on store broke. I don’t know how to fix it. I restored a snapshot from a few hour earlier, but that didn’t work. Can anyone help? Found this in the system log:

19-05-13 06:21:16 INFO (MainThread) [] /addons access from a0d7b954_ide
19-05-13 06:21:16 ERROR (MainThread) [aiohttp.server] Error handling request
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 418, in start
    resp = await task
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 458, in _handle
    resp = await handler(request)
  File "/usr/local/lib/python3.7/site-packages/aiohttp/", line 119, in impl
    return await handler(request)
  File "/usr/src/hassio/hassio/api/", line 144, in token_validation
    return await handler(request)
  File "/usr/src/hassio/hassio/api/", line 32, in wrap_api
    answer = await method(api, *args, **kwargs)
  File "/usr/src/hassio/hassio/api/", line 158, in list
  File "/usr/src/hassio/hassio/store/", line 41, in name
    return, UNKNOWN)
  File "/usr/src/hassio/hassio/store/", line 36, in data
KeyError: '82ccd6b1'
1 Like

I’d like to know as well…
I just had to reinstall HA on a new microSD card. I had my config saved, but would like to install a few add-on’s I hadn’t backed up yet.

My system has been running perfect and I am getting the same error so it’s not something that you did wrong.

It’s good to know that I am not the only one. Is there any way to remove the last installed addon manually to check if this wil work?

I can also confirm that issue.

I’m also facing this issue.

Did anyone manage to fix it?

Same issue here

Anyone else seeing Not Secure with HTTPS with the line through it too thinking it may be linked

I’m getting the same issue too…Our installs are fine, it’s something external.

I have the same issue.
HA answers with a HTTP error 500 (internal server error)

Extern adres:x.x.x.x:443

Same issue here. I’ve got a running system on a Pi that has been fine and suddenly now comes up with this message. I was also in the process of setting up a VM and did a clean install, same error so I’m pretty certain this is an external problem.

Hi i ve same issue i thought it was my config fault but so seems no. btw all the other HA stuff working fine

Same error here!

FWIW, I’ve raised this in the forum as in my opinion it’s less of a configuration issue and more of a problem.

1 Like

Let’s try to find the root of the problem: I entered a wrong URL in the add-on store page first. After that I added a github URL for ESPhome.

It might be coincidence, though. What did you do to trigger it? Or is it really a case of waiting untill the next update?

I didn’t do anything. In fact I was actually installing a instance in a VM on another machine to try out and the add-on store on that fresh out of the box install came up with the error.

+1, same here. “Failed to fetch add-on info” message

I also didn’t do anything.
I’m guessing one of the manually added links to the repositories of other users got broken? Just a wild guess. I think I have added about 5 repo url’s. I remember the official hass io add on from Frenck and I remember one from user called Romkabouter or something like that. And perhaps one of Snips. Not sure, though.

Do you know where Hassio does store those repo links? I have only one extra Repo, so if that one is broken we have it. Just need to see the config as i dont remeber which one it was

I’m not a developer, but with some grepping I found the repository url’s.
Can you ssh into your system and execute the following and show me what you got?
find /usr/share/hassio/addons/git/ -name repository.json | xargs cat
I have these three:
“name”: “Community Add-ons”,
“url”: “”,
“maintainer”: “Franck Nijhof [email protected]
“name”: “Romkabouter’s Hass.IO add-on repository”,
“url”: “”,
“maintainer”: “Romkabouter [email protected]
“name”: “Snips Repository from Tod Schmidt”,
“url”: “”,
“maintainer”: “Tod Schmidt [email protected]