Add ons fail with no host internet connection

I realise that there are many similar issues but I have NOT been unable to find a solution to the problem lots of discussion and some of it WAY over my head

The issue
select an add on > install > fail with message AddonManager.install blocked from execution , no host internet connection

I had installed a number of add ons, File Editor, Terminal & SSH, Samba Share , Studio Code Server and for one of these I had received the same failure message, my resolution to that had been to reboot my host PC and wait till the next day. On the next day the installation was fine :slight_smile: .

Most recently I tried to install VLC got the same error no host connection reboot x n did not fix the problem :frowning: I had thought it might have something to do with my location / time zone so have tried at different times but get the same result.

Much searching followed and whilst there are many words on the issue I could not find a fix that I could apply. :unamused:

my setup
cpu
product: Intel(R) Core™ i3-3240 CPU @ 3.40GHz
vendor: Intel Corp.
physical id: 1
bus info: cpu@0
version: 6.58.9
size: 3245MHz
capacity: 3400MHz
width: 64 bits

Distributor ID: Ubuntu
Description: Ubuntu 22.04.1 LTS
Release: 22.04
Codename: jammy

Virtual machine manager
QEMU/KVM home assistant

Home Assistant 2022.8.6Supervisor
2022.08.3Operating System 8.4
Frontend 20220802.0 - latest

Add ons
File Editor
Terminal &SSH
Samba Share ( had failed once with no host but powered down then up and it worked 10 hours later)
Studio Code Server ( had failed once with no host but powered down then up and it worked 10 hours later)

uninstalled 
     Samba Share 
     Studio Code Server

Integrations
HACS was installed after the above problem was discovered - no issues getting that to install :slight_smile:

**network **

ha network info
host_internet: false

I have access to the internet from firefox browser so it seems to me that only HA does not know how to get to the internet

Resolution

I am hoping there is a very simple command that can fix the routing/domain/whatever to allow me to install add ons :pray:

Well to others that may have this issue.

I tried to reinstall the ha a number of times and had no luck each time the ha network info host_internet: false.

So decided to go back to scratch, reinstalled a clean Ubuntu virt-manager and a new ha and hey presto host_internet:true

I have no idea what might have caused the host_internet to fail and spent hours trying to fix it, reinstalling from scratch cost less than an hour.

Running into the same issue you did, however, rebuilding it from scratch on my pi has not fixed it.
I can disable the check and install add-on’s just fine. Something that checks to flip the bit for host_internet is not getting out of my network.

Same problem I had. Thanks @KeiSenpai, your idea helped me.

I managed to disable the host_internet check: ignoring the internet_host condition.

ha jobs options --ignore-conditions internet_host

and to reset it back to normal, after addon update completed:

ha jobs reset