Add support for Levoit Classic 600S Smart Ultrasonic Top-Fill Cool Mist Humidifier in the VeSync integration

I recently got a 600s Humidifier. I notice the 300S is in and per the thread working.

Can someone look and see if the 600s can be added too?


I am more than willing to assist in getting this thing connected to HA.

I’m working on updating this integration (on the shoulders of others). Currently it (hopefully) works for all humidifiers, but a similar fix will be needed for the fans so all models in the library work with HA. I don’t have a fan so to do it, I’d need a tester (or 2).

I have a test repo and created a new topic. VeSync development particularly for Levoit Humdifiers

Checking-in: Maybe someone found a way to integrate Levoit LV600S with HA? Would be great to have this working!

Our LAP-C601S-WUS, which shows as CORE 600S, showed up on HASS today using VeSync integration ( and shows PM2.5, filter life values, FYI.

1 Like

Please add official support!!

For now I am using vlebourl/custom_vesync: Custom VeSync component for Home Assistant ( which is working fine but it would be good to add official support since VeSync is already there (just not for humidifiers).


Does it work with LV600S?

I’ve tried to add the GitHub - vlebourl/custom_vesync: Custom VeSync component for Home Assistant and it successfully detected my LV600S. Thanks!

Did you do anything special to get it to show up? I have the HACS integration installed and nothing changes when I call the VeSync: Update devices service.


Thanks a lot!
Works great for my LV600S added with HACS integration.

Which steps did you do?
HACS is installed?
Added custom repository with url of git repository?
Custom VeSync downloaded?
HA fully restarted?

HACS has been installed forever, and updated to 1.31.
Added through HACS with URL of git repository. Installed no problem.
Installed service.
Called the VeSync: Update devices service in Developer Tools: Services.
HA Fully restarted
I see the service, but there is nothing listed under it.


Do you see entries in the log?
Settings → System → Logs

When i’ve installed the not customized VeSync integration, i had errors their from my Levoit.
As i can see on your screenshot, you dont have the customized VeSync integration.
It must be the default vesync integration, that you have installed.
It should be looking like that, with additional box icon:


Great call on the logs. I found this:

2023-03-31 11:53:28.847 WARNING (MainThread) [] My Humidifier - Unknown device type - LUH-A602S-WUS

OH! I didn’t know anything about a customized VeSync integration. There was only the one that I got from HACS. Where do I find the customized one??

Deinstall the current VeSync integration.
Restart HA completely.

Go HACS-> Integration->3 dots upper right corner → customized repositories → copy the following github repos URL:

Download it, install it, fully restart.
Check VeSync integration again, login :slight_smile:

1 Like


Thank you for your time, it is much appreciated. <3

1 Like

Thank you, this worked! Everything is still unavailable within the humidifier, but it is recognized at least. ::man_shrugging:

edit, I move it and it lost access to my 2.4ghz network. I had to remove it from native app, reboot router then it saw the 2.4 and I am now up and running!

Glad to hear, that everything is working now.

The Custom VeSync I used here worked on my LV600S.

However, I have two of them and it seems like only one is being shown in HA (11 entities).

Anyway to make my other LV600S show up as well on the same account?