Add support for Odroid M1

Please add support for Odroid M1 kernel.
Thank you

The M1 indeed looks like a very interesting platform to run HAOS on. However, currently it seems that in upstream Linux support for the Rockchip RK3568 is in early stages, and ODROID-M1 support is currently completely missing (which make sense since the board is really new). I’ll keep an eye on how upstream support for this board comes along.


I just got 3pcs Odroid M1 and succesfully run k3s and Rancher. Home assistant can be installed from helm chart… But managing addons from cluster and Home Assistent is completely separate things… HAOS has so many things right… If some day HAOS can be installed Odroid M1 NVMe, I definetely throw away High Availability over easy management.
a.k.a Just Following This Topic.


I have just got mine, was not careful as it was purchased specially to run HASOS, now I will wait until it is supported.

1 Like

I will receive two M1’s next week with a samsung M2 980 pro ssd.
Supporting image of home assistant will be much appreciated!

1 Like

Just adding in my vote to get M1 support! Seems like we’re waiting on external factors right now but I’m excited to use mine to run HA!

1 Like

Is this going to be added?


What about running it in a Docker container?
p.s. sorry if it’s noob question, I’m really new to Home Assistant and just received Odroid M1

1 Like

Got two of them with a 980 SSD nvme and did a supervised install of HA using the Ubuntu image from ODROID.
Seems to be working OK with the exception of a warning that it is not a supported OS within HA but that is logical since Debian is the official supported OS for this.


Do you have a link to a tutorial or explanation for the supervised install of HA?
I run ubuntu on the M1, but i have no luck using docker CE. (and i want to have a supervised install)


For installing on the nvme SSD just exit to shell within petitboot:
ums /dev/nvme0n1

and flash the Ubuntu image on it using an OTG USB cable, but I assume you already did this.

Update the Ubuntu install:
sudo apt update
sudo apt ugrade

Then follow the supervised install from HA github using step 1 and 2.

Then use the os-agent_1.2.2_linux_aarch64.deb at step3 and verify after install that it is working ok by using:
gdbus introspect --system --dest io.hass.os --object-path /io/hass/os

it should return no errors.

Install AppArmor:
sudo apt update && sudo apt -y install apparmor

Add AppArmor as Linux kernel boot parameter (else HA wil give a warning about it):
sudo -i
sudo echo "apparmor=1 security=apparmor" > /etc/default/grub

Execute step 4 (install homeassistant-supervised.deb) of the HA github tutorial and select ODROID N2 and reboot after that (give it some time before the reboot).
After the reboot just wait for it and then access HA via the url.

This worked for me…


it can work in docker container, but my goal is, that I can use the OS, because I have a dedicated server for Home Assistant.

Add sudo echo "systemd.unified_cgroup_hierarchy=false" > /etc/default/grub

before step 4 so you won’t have this error:

/var/lib/dpkg/info/homeassistant-supervised.postinst: line 145: update-grub: com dpkg: error processing package homeassistant-supervised (--install): installed homeassistant-supervised package post-installation script subprocess Errors were encountered while processing: homeassistant-supervised


I used this tutorial on an Ubuntu installation, HA works great.
Also tried a Odroid Debian 10 and 11 installation trough netboot to get rid of the ‘unsupported installation’ message. HA works on both versions. But I couldn’t get apparmor working, meaning the ‘unsupported installation’ message is still there. So I ended up switching back to the Ubuntu setup.

Would love to see a HASOS build for the M1.

the odroid-m1 seem to use simplier u-boot than other odroid (n2/c2/c4 and xu4) supported by haos.

  • odroid-m1:software:partition_table [ODROID Wiki]
    They use Rockchip RK3568B2 in place on Amlogic ou Samsung Exynos.
    they have similare GPIO.
    is cortex-a55/arm8a quad core like odroid-c4.
    normaly supported by linux kernel v5.x (already used by c2/c4/n2 and xu4).

in Getting Started with Home Assistant Operating System Development | Home Assistant Developer Docs haos build getting started guide we need to copy buildroot-external/configs/odroid_c4_defconfig to buildroot-external/configs/odroid_m1_defconfig to start.

i’ve seen also hardkernel package for u-boot image, operating-system/buildroot-external/package/hardkernel-boot at dev · home-assistant/operating-system · GitHub as to be modify.

and also the rpi-rf-mod packages, operating-system/buildroot-external/package/rpi-rf-mod at dev · home-assistant/operating-system · GitHub as to be modify.

i’m not sure about the modification of the u-boot build…

i’m trying to that on my fork: GitHub - mcarbonneaux/haos-odroid-m1: Home Assistant Operating System

1 Like

in fact odroid-m1 kernel are based on rockchip bsp kernel… that are 4.x kernel…
and no mainline kernel are integreting all odroid patch…

on arch forum they speek about odroid-m1 support…

i found one that are porting odroid-m1 patch to 5.18 mainline kernel…

i found some submition to the 5.x kernel…

especialy the dts submition:

armbian port:

1 Like

Got my M1… can’t wait to have full HASSIO support :slight_smile:

1 Like

i’ve build all package, uboot and kernel, but i’m blocked at that download docker image, and try to download image with the new name of the new board…

/build/buildroot-external/package/hassio/ "aarch64" "odroid-m1" /build/output/build/hassio-1.0.0/stable.json observer "/cache/dl/hassio" "/build/output/build/hassio-1.0.0/images"
flock: getting lock took 0.000036 seconds
Skipping download of existing image: (digest sha256:8a5ff0a82e329edc9f5c99a93fa44c1d3b46d7edaf3257ad29bfe1c021024367)
/build/buildroot-external/package/hassio/ "aarch64" "odroid-m1" /build/output/build/hassio-1.0.0/stable.json core "/cache/dl/hassio" "/build/output/build/hassio-1.0.0/images"
FATA[0001] Error parsing image name "docker://": Requesting bear token: invalid status code from registry 403 (Forbidden)

in the Getting Started with Home Assistant Operating System Development | Home Assistant Developer Docs they dont talk about that…


Eagerly awaiting being able to decommission HAOS on my old xu4 and light up my m1!

The m1 with nvme storage is a weapon from a performance point of view. Hopefully mainline kernel isn’t far away.

Count me in. Also using a M1 now :slight_smile: