Add support for Odroid M1S

You can try, but I dont think Petitboot will be able to boot HAOS sd card. (Although it seems it might on Odroid M1? but I dont have one to test.)

When HAOS is on the eMMC, it wont boot the Hardkernel images without shorting the maskrom pads per info on the Hardkernel wiki page.

Thus there is no easy way to dual boot HK OS and HAOS. But should be possible once Debian or Armbian images are available.

Right, this is exactly why Hardkernel have the USB sdcard image for UMS. Boot the SD card, flash HAOS to the eMMC.
However maybe the Odroid-N2+ instructions I linked previously may also work? But the SD card method is surely simpler!

I added the basic info here you can reference from, I dont expect new users to ever see this page, they will most likely head straight to main home assistant.io installation guides!

1 Like

This page is so valuable! It essentially contains most important information that should later be found in the “normal” installation docs as well.
Your effort is so appreciated!

I could not get this working, when I shorted the pads and booted with the recovery image, the m1s boots and will have a solid red and blue led (instead of blinking blue led). But when I connect it to a usb port (via the otg usb), it does not show itself as a mass storage device. any tips ?

Did you used an sd card with the ‘ODROID-M1S_EMMC2UMS.img’ image and short the maskRom pads (for 4-5 secs) directly after powerup?

I just gave this method a shot:

  • I brought my board to HKs initial state by flashing their installer image to eMMC.
  • The board booted into the OS selection screen
  • exited this screen by choosing cancel
  • typed the following: ums /dev/mmcblk0
  • connected the board to the host PC via micro-USB
  • nothing happend, no mass storage device detected

Sorry the N2+ method seems not to work for M1S.

So I booted again with HKs eMMC-to-UMS SD card, the board got detected as mass storage and I was able to flash and boot into most recent HAOS image :slight_smile: .
So currently your instructions from HERE are already complete.
Strange: I got no HDMI output. is that normal?!

Ok thanks for testing that.

Yes, but these need to be integrated into the website :wink: Most users wont ever see the above linked instructions.

Yes I think so, see the comment under console access in odroid-m1s.md. Although you probably should get a login prompt on hdmi without doing anything.

The solid blue LED is correct that’s exactly what I got, I’m pretty sure that means the SD card has booted for USB.

Are you booting with the SD card first then connecting the USB cable?

after a couple of times it worked, don’t know what I did differently. When the 2 leds are solid, then connect to the pc to flash. oh well, it works now and this rc1 should update via the normal procedure, so all is fine now.

1 Like

probably just a timing thing. If you short the pads for too long it might fail to detect the eMMC.

Thank you, you are totally right about HDMI. I understand it so that HDMI is switched completely off by default. It’s all about to RTFM :wink:

About documentation:
got it. I will try to edit the Common Tasks page as well as the Installation page regarding ODROIDs hopefully today evening.
Is this need to be done through github? I am not that familiar with the github workflow. I once tried to create a pull request for another project and totally failed :sweat_smile:

Right until you set console=tty0, its not connected to anything. Systemd uses that console value to activate getty (which provides the login console).

Yes all the website is on github, however since you are just editing markdown files you can probably do it all through github UI, rather than having to locally clone the repo.

Yep, thats what I just did recently. I already added a few things. But some things are still missing like the affiliate links (like for the M1, N2+ and so on) as well as the dynamic references to the entire firmwares do not work because they are just not present yet. I will try to find out of there is still something else wrong with my changes but for now I think it looks quite okay.

not sure if this is what you are referring to, but for the firmware links, odroid-m1s will need to be added here:

However that probably needs to wait until its added to the version json

is the eth interface connecting at 1gbps for you guys? It seems to be limited to 100mbit here

my m1s is connecting at 1gbps to my 1 gbps switch

OTA updates are now active, so you will get notified of next updates.

2 Likes

ODROID M1S is a very suitable device for home assistant.
Thank you for your effort.

Yes exactly. I did not know the exact file that you referred to, but I already thought that the official firmware version needs to be in place before those dynamic links work (sorry, I just don’t know the correct term).
Maybe I just create a PR and see if it passes any reviews :sweat_smile:

It is there now, so the firmware links will work once adding odroid-m1s to the list

sounds good! There were some updates to docs on the operating-system repo also, make sure to check those again!

Odroid M1S support has been officially released as part of OS 12.0.

@andrewraj Lets close this feature request now.

Can continue discussion in a new thread.

2 Likes