Add support for Tesla Powerwall

They aren’t making it easy, but keep clicking though and you can still get to the local login screen.



1 Like

I’m VERY new to HA, but I seem to have got the Backup Reserve working as described above.
But, I was looking at the default “Energy” Dashboard in HA and trying to configure it to take the data from the powerwall as this seems to have everything this page needs.
But when I attempt to add a source of information, my Powerwall isn’t showing as a sensor.
Following the link to “learn more about statistics” points me to the Developer Tools > States section of HA.
Here is states that the “device_class” must be “energy”, but when I look at my entity “sensor.ger_y_nant_grid_power” the “device_class” appears to be “power”.

Am I missing something as the support says I should create a support ticket, but since I’ve only been on here about 5 minutes, I thinking I’m missing something…

Any help would be appreciated for a newbie! :slight_smile:

1 Like

^ No I don’t think you are missing anything
Whilst setting the backup reserve slider using this HACS app is useful (it still doesn’t sync directly with the Telsa app)
However, with this app, you can’t see any appropriate import/export battery sensors
Unlike the official HA app, in this app, there are no sensors for energy in and energy out of the battery that can be added in the Energy card of HA (or none that I can find)
So I went back to the official one (as it seems both can’t be run together)

I think Tesla must have pushed out some firmare update yesterday? Over night my PW did not switch over to the charging mode and it also happened to my firends system. We both use the Tesla Custom app to switch to grid charging and to control the over night charge. @markpurcell are you aware of any issues and possibly updates for the integration?

Just to confirm that I am also seeing the same issue.

1 Like

THere must have been a lot of 0% SOC’s this morning :slight_smile:

Thank you for the fixed update! :heart_eyes:

Yes have been living the drama all day with the lack of control.

First we thought it was the FleetAPI, of which we don’t have an energy solution writing just yet.

But it turns out the need was for an X-Tesla-User-Agent header.

If you update manafest.json in the tesla_custom folder to the teslajsonpy version 3.9.9 you can control for another day.

1 Like

I’m brand new to HA and just setting up HA on a RPi5, and get an error when trying to add the Tesla integration. I have SolarEdge inverters, and 2 Tesla Powerwalls, and can’t get the Tesla integration to connect. I have set a static IP for the Tesla Powerwall, and tried using the last 5 of the password listed in their Control panel in both upper and lower case and it still gives an error. I have the usage module with SolarEdge, but HA does not seem to have an option to use Solar Edge as both coming in from the Grid and Exporting that I can see.

Hi Paul,

Can you check if the installer changed the original password? Can you log in to the actual PW gateway using the web link but with your PW IP: https://192.168.86.61/api/system_status

As with Mark’s post above: Add support for Tesla Powerwall - #405 by markpurcell