Add User Authorization Error

I enabled the new home assistant authorization and on a restart, it let me set up my admin user with a password. I don’t have any menu item to add new users though, and when navigating to http://myhaasip:8123/config/users/ and trying to add a user I get an authorization error.

Any ideas on how to fix this?

There’s an issue when http trusted_networks enabled.
Maybe related?

UPDATE: Starting from 0.77 beta 1, you can remove whole auth_provider section, HA will auto load trusted_networks auth provider if need.

If you enabled trusted_networks, you need add “trusted_networks” auth provider

    - type: homeassistant
    - type: legacy_api_password
    - type: trusted_networks

Then login with trusted_networks when you access from a trusted network.

Thx @awarecan for the reply.
Have - type: trusted_networks enabled, but on login i get only Home Assistant Local and Legacy API Password.

BTW: The log says on startup:
2018-08-22 02:19:34 WARNING (MainThread) [homeassistant.components.http] Experimental auth api enabled and legacy_api_password support enabled. Please use access_token instead api_password, although you can still use legacy api_password

Aha, my bad. This feature is not in 0.76, will be landed in 0.77 for sure.

Adding trusted_networks gave me the user manager back. I had to disable trusted networks under http before it would let me add users.


I had this configuration before 0.77, (can’t remember why, is my host running HASSIO). DO I need to take trusted_network away?

  api_password: !secret api_password