Add Z-Wave JS integration

Hey guys
I’m fairly new to Home Assistant and was trying to integrate my Aeotec Z-Wave USB stick and nano dimmer. For this purpose I wanted to add the “Z-Wave JS” integration to my Home Assistant.
Unfortunately I already fail at a very early stage when I get asked for the URL.
I understand from the documentation that the URL in question here would be the one from the docker.
I have my Home Assistant installed on my QNAP NAS via Container Station.
The container network settings are set to Bridge and Static IP Adress.
My guess for the URL would have been “ws://IP-Adress:8123”. If I type this in I get the message “failed to connect”.
Any hints are much appreciated!

Port 8123 is for Home Assistant, you want port 3000 for the websocket interface to the zwave_js server.

1 Like

as alluded to above you first need to install some version of a zwave-js server.

you can run the zwave-js add-on or the zwavejs2mqtt add-on if you are running HAS Supervised or you can install the zwavejs2mqtt docker image if you don’t have the supervisor.

then you will enter the URL:3000 as n oted above.