Add Zwave2mqtt switch to MQTT / HA

I have an issue that I can’t get my Z-wave switch to work with HA.

I have:
RPI 4b
connected Aeotec Gen5 Z-Wave USB Z-Stick via a USB hub

Home Assistant 0.116.3
Addon Mosquitto broker 5.1
Addon Z-Wave to MQTT 0.8.1

External hardware
Z-wave connection to Aeotec Dual Nano Switch with Power Metering
Shelly H&T wifi Temperature and Humidity Sensor

MQTT running fine, the Shelly H&T is connected to it and give readings

Zwave2mqtt is installed via this manual

Zwave2MQTT is running also, the z-stick and nano switch are found and can be controlled via the zwave2mqtt webpage.

In configuration.yaml added these lines

  discovery: true
  - platform: mqtt
    unique_id: IRpanel_switch
    name: "IRpanel Study"
    state_topic: "zwave2mqtt/4/37/2/0"
    command_topic: "zwave2mqtt/4/37/2/0/set"
    payload_on: "TRUE"
    payload_off: "FALSE"

Zwave2mqtt is conigured like this

Screenshot 2020-10-17 at 13.28.30

By entities is see the switch, but can’t control it.

Another thing is that in zwave2mqtt i have 3 toggels for this switch. 1 and 2 turn on/off the light thats connected to it. the 3rd toggel doesnt do anything.
Also you have to enable the toggle 2x times to turn the light on and 2x to turn off. first time enable the light, second time does nothing, 3rd time turn the light off and 4th time does nothing.
If you dont enable the toggle 2x it doesn’t turn off.
The same with Toggle 2.

Found the issue in Zwave2mqtt configuration.
by MQTT Host url. needed to just be the local ip address.

Now they show up in MQTT. only the entities are disabled.
Checking now why this is.

After several hours i moved away from Zwave2mqtt and configured open Zwave beta. get a lot further with this add-on.