Added USB device to my device and ZigBee stopped working

I have a Gigabyte Brix / (NUC compatible) with HAOS.

Been busy with Frigate, and plugged in a Google Coral USB stick to my device. Ever since my Google Coral is in my device, the ZigBee stack stopped working. Non of the Zigbee devices are working. Frigate seems to see my Coral Stick.

I removed the Google Coral stick, rebooted, and Zigbee started working again.

How can I fix / troubleshoot this?

Additional info;

I have 4 USB ports in my device; stick
-conbee 2 for zigbee
-google coral
-slimme meter USB to P1 (BUSNUM: ‘001’ DEVNAME: /dev/bus/usb/001/002)

Properties for Zigbee add on;


Serial port

Properties for hardware; Conbee;
BUSNUM: ‘001’
DEVNAME: /dev/bus/usb/001/004
DEVNUM: ‘004’
DEVPATH: /devices/pci0000:00/0000:00:15.0/usb1/1-3
DEVTYPE: usb_device
ID_BUS: usb
ID_MODEL_ID: ‘0030’
ID_SERIAL: dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2292513

  1. Did you install HAOS directly or in a VM?
  2. Do you see any error in the logs?
1 Like

Using serial/by-id is already correct. So the problem is that OS, HA, or ZHA does not detect it after reboot.

ConBee adapters are infamously known to be troublesome during reboot, with the workaround being to reboot again or physically unplug and replug the ConBee adapter.

If you are using the built-in ZHA integration then recommend you buy a newer Zigbee Coordinator adapter and migrate to that after flashing the latest firmware, which is easy if using the ZHA integration, see →

For tips on newer Zigbee Coordinator adapters check out this → Zigbee buyer's guide

Other than replacing it with a newer Zigbee Coordinator adapter there are a few things that you might consider doing regardless which could possibly help make that specific problem less likley:

PS: If you said you where using Home Assistant in Docker then I would also have advised you to configure Docker Compose (but you did not so that should not apply to you) →

PPS: Off-topic but recommend following these unrelated tips as well which include the USB 2.0 hub tip and also using a long USB extension cable to help avoid EMF interference → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

1 Like

Great tips,

HAOS is installed directly on the hardware. If you install it as a container, it’s no longer called HAOS right?

The USB hub, I was afraid this remark would come, actually popped my mind when writing my original question. That’s a nice work around. But it would be avoiding the original problem. For me that’s like; you can also walk to your lamps an press the switch on it.

Updating the firmware, great idea, gonna try that.

I think, first, I’m gonna try to power off my NUC. Maybe reorganize and unplug the USB connectors.

-Power off and reconnect the ConBee didn’t work

-Power off and rearrange USB ports; worked

And with rearrange; there are 4 USB poorts in my NUC, I just put the Google Coral in a different USB poort. And apparently that did the trick, everything works now…

Thanks for the help

1 Like

Note that the ConBee 2 is old and does technically not even support Zigbee 3.0 (though can use Zigbee 3.0 devices in backwards compatible mode) and is does not have very good reception so there is many others reasons to upgrade.

Still recommend buying both a powered USB 2.0 hub and a newer Zigbee Coordinator adapter like example ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus” (model “ZBDongle-P”) based on Texas Instruments CC2652P) → ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" (model "ZBDongle-P") based on Texas Instruments CC2652P +20dBm radio SoC/MCU

See the many many reasons why here → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

You may recommend. But the heating in my house depends on zigbee. I would be scared as hell if something goes wrong. And for the usb hub, I have enough wires already. I’m trying to cut down on adapters.

If I ever buy a new zigbee , it gonna b the sonoff one. I have great experience with sonoff. But I don’t see any reason to do this on short term. Because of costs, risk and time. I’m a very busy man…

If using the ZHA integration then there is no problems migrating as long as you first have upgraded ConBee firmware and a backup is done so you can restore if needed to go back →

But you know that you should at least use a long USB cable for any Zigbee Coordinator or you should not be suprised if you get wierd and intermittent delivery errors or latency problems as well as battery drainage on devices due to EMF interference which force messages to be resent many times, (and the ConBee uses and older radio chip thah is known to be more susceptible than newer radio chips in new adapters), again you really need to read this → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Adding a few dedicated Zigbee Router devices would make that less noticable, and the more Zigbee Router devices the better, however it is still highly recommend to take actions to avoid interference.

At least you will be a aware.

Hadda, I appreciate your help. And I think your intentions are good.

But, my question was about USB devices. That’s now solved. Your remark on the conbee showcasing wierd USB behavior pushed my in the right direction.

I have two long USB cables that ensure my wifi/zwave/ZigBee are not physically close to each other. But my ZigBee and zwave networks are working fine. So that ain’t broke. So I’m not gonna potentially risk spending weeks trouble shooting why everything stopped working because I upgraded my USB stick. Again, I don’t have the luxury of that much time.

Sorry for bothering you but others with ConBee might stumble on this thread and see the advice, so my replies are not only directed at you but everyone who might read this.

I also adere to the principle of not fixing what is not broken, however, the fact is that the outdated ConBee 2 (based on old chip and firmware that is no loger maintained) and it should be considered obsolete today (as it only support Zigbee 1.2 version and not support Zigbee 3.0), …so your ConBee may not broken but it is definitivly at the end of its life and so anyone owning should consider replacing it regardless.

FYI, those that migrate away from it can still repurpose the hardware as Thread Border Router if want to test the experimental Matter integration: