Added Xiaomi Mijia GW via Homekit controller, but buttons are not entities

Tags: #<Tag:0x00007f739f47cad8>

Hi everyone,

I’ve added the GW without any problems ( I have the Mio controller v3 ), and it’s seeing 5 devices and 8 entities.

I have two wireless buttons, connected to the GW without issues and they work. However, in the Entities section I only see

sensor.stateless_programmable_switch_battery but not the actual switch.

The actual switch is under devices. However each device only the entity about the battery. I want to be able to use the switch as a normal (stateless ) switch to toggle different automations.

I tried everything I could think of, but wasn’t able to make it work at all. I’m open to any ideas.

That’s not the way it works. If you want a switch to toggle an automation just create an input boolean and use it for that.

Since they’re stateless, they don’t have entities. They trigger an event instead.

Check in the Developer Tools - Events tab, you should see a HomeKit event listed there. Subscribe to it and see what comes through when you press the button.

I tried everything, but there’s no Homekit event coming (nothing at all). In the Mi Home (android app) the button fires the event, but not in Home assistant.

Everything else on the Homekit Controller works as expected …

This is a known problem. At the moment, the Homekit component in Home Assistant does not support stateless switches. Until the feature is added, there is nothing we can do unfortunately. We can push for this feature to be added as soon as possible!