Adding a Localbytes Esphome plug to HA [SOLVED]

First post.
I purchased one of Tasmota and ESPHome plugs (sockets)

Previously I’ve used other Tasmota plugs and found them quite easy. Get them on the network, edit MQTT in the webserver and it appeared in HA.
The Tasmota one was easy and took about 30 seconds.

Someone said try ESPHOME it auto discovers. no curl, http etc required - literally just plug and play.

When I try and connect it says “can’t connect to ESP”
I tried putting homeassistant.local in the address but this doesn’t work.

Can’t connect to ESP. Please make sure your YAML file contains an ‘api:’ line.

Where do I edit this YAML and what do I put in?

The plug seems to have an IP address of that isn’t of my subnets?
How do I talk to it to configure it?

I looked on Tasmota / ESPHome Smart Plug | Power Monitoring | Local Bytes but nothing about ESPhome.

What am I doing wrong?

Some screenshots

Clicked Open WebUI

homeassistant.local does not work because the dialog box is asking for the host/ip of your esp node, not your home assistant installation.

How do I find out what that might be?

How did you flash it and can you show the code you used?

Local bytes say it is already flashed as esphome.
When I try and connect to it, it comes up on an address not in my lan
my lan is say
it comes up

How long do I have to wait until the forum will let me post more than one image?

try configuring an IP on the same subnet on your device, for example then connect to your ESP and change the IP to one in the correct subnet.

I tried static. Tried that I can ping it. But there is no web server. I should have port scanned it with nmap.
Another person on here told me esphome was plug and play easy, much easier than tasmota.
I dsiagree so far.
Tasmota. I put it on Wi-Fi. Opened browser. entered my mqtt server and bang it appeared instanty. Thus far I’ve spent hours on and off getting nowhere. Maybe it’s faulty

@mrg9999 Have you connected to the AP on the ESPHome device to configure it’s WiFi settings? When you power up the device do you see a new AP in your WiFi list?

It comes up on wifi, can be pinged but no webserver. I tried the Esphome addon but it askes to open a serial connection and there is no way (I can see) of connecting a serial cable.

My understanding of the initial ESPHome configuration is that it needs to be configured to connect to your WiFi? Have you connected to the default/initial AP so that you can enter your WiFi credentials into the plug?

I don’t actually have one, but I do have a Tasmota version that I’m going to migrate to ESPHome, so my comments are purely based on what I’ve read on the LocalBytes guide.

If you look at your WiFi list do you see something like Localbytes Plug PM and then a string of numbers?

I’ve dozens and Tasmota and clones (Sonoff, Shelley, Byron, Lightwave, Teldus) and all work as expected.
I bought one of these preconfigured ESPhome from Localbytes because someone said they are zero configuration, literally plug and play.
Not my experience so far.
Their Tasmota was
get on network.
browser / curl to ip address. Add MQTT server and creds, reboot and appeared in Dashboard in about 30 seconds.
I’ve wasted hours on this so far. Maybe it’s broken/faulty?
And who puts the button onthe side, why not the top above the earth pin so that it works next to other plugs.

I’ve connected it up to a RPI and solenoid to see if sending SOS on the power button helps and cycling it’s power through another smart socket

It’s on the network and appears as Localbytes Plug PM (no numbers)

As I said I was going to convert one of my Tasmota devices to ESPHome, so am very interested in how this goes. From the ip address you posted above it looks like it’s in AP mode and waiting to be configured to connect to your WiFi.

If you try and connect to the Local Bytes Plug AP and then open a browser what happens? I find this step easier on a mobile device.

Nothing. or connection refused. I can ping it fine.
Tried hammering the on/off button and power cycling it
Now it comes up as localbytes-plug-pm-Fá/*}p“
Tried some more above
Now it comes up
with a page I can edit

and it’s in HA
Is it always going to be this hard?

Glad it’s sorted, a bit worried about making the swap myself now. However, I’ve had something similar with anything that goes through that initial AP configuration. Would you mind making some comment about the power utilisation once you’ve got it settled in?

I’ll find a suitable load and connect it up and have it power up, wait power down and repeat for a while and see how it goes. My pressure washer has already blown up a couple of TPLINK ones