Adding Broadlink TC2S-UK and SP4L-UK to HA

Hello All,

I’m a new HA user and not a coder or Linux user.

I have Home Assistance installed on Rasberry Pi:
Version core-2021.4.6
Operating System Home Assistant OS 5.13

I recently installed the following Broadlink products:

  • Broadlink RM4 PRO (RM4-PRO)
  • Broadlink Bestcon TC2S UK standard 220V 436Mhz Smart wireless Switch Wifi light Switch work (TC2S-UK)
  • Broadlink RM4 Mini Sensor Accessory, Temperature and Humidity Monitor USB Cable. (HTS2)
  • BroadLink Smart Plug Wi-Fi with Night Light. (SP4L-UK)

All the above devices work without any problem on Broadlink App and Google Home, but not Home Assistance.

HA automatically found RM4 PRO and the sensors but not the rest of the devices, so I have one Device and three Entities.

For days I researched how to add the Wall Switch (TC2S-UK)
and the Smart Plug (SP4L-UK) without any luck.

So can someone help me with how I can add them to the system?

Hi @RaedS. I need the log message “Unsupported device…” to add support.

Thanks for your reply @felipediel,

I hope I understood you correctly, I added a new Broadlink Integration and in the IP address field I wrote the IP address of Smart Plug (SP4L-UK) and I got an error message and below the log entry:

Logger: homeassistant.components.broadlink.config_flow
Source: components/broadlink/
Integration: Broadlink (documentation, issues)
First occurred: May 2, 2021, 10:45:30 PM (2 occurrences)
Last logged: 5:45:06 PM

Unsupported device: 0x7587. If it worked before, please open an issue at

I didn’t add Wall Switch (TC2S-UK) because it’s not a WiFi device, it connects to RM4 PRO (I think via RF).

Added, it will be available soon. Thank you!

1 Like

Thanks @felipediel,

But how can I update Broadlink integration once it gets updated? should I copy it in the custom_components folder then add some codes in configuration.yaml? or there is another way to update it in the integrations section under Configuration?

No extra configuration is necessary, we just need to wait until the update reaches the end of the line.

1 Like

Hello Felipe. I see that you are a specialist in the field and that is why I want to draw on your experience.
I have several SP4L-AU devices that were not recognized by HA at first, but after reading several posts in which you are, I managed to add the following line to the and it worked:

0x757b: (sp4, “SP4L-AU”, “Broadlink”),

One day after my achievement, a new HA core update (core-2021.9.2) is released and the commit is cleared.
Do you know who contributes in HA so that the line that I added is final? Can I make a script to run after an update?
From already thank you very much!

Hi Damian. Your device is already added and will be supported in the next version of the library, but I still need to find time to finish it and release it to hass.

Felipediel, good day and Happy New Year! I am also struggling with TC2S light switch using RM4 Pro device to be added to Home assistant. TC2S uses RF protocol and I can’t seems to learn the RF codes like it use to be on the older version of RM3 Pro.

Any advice on this? It would be very much appreciated if you could help me out.


Hi Felipe - Any luck yet to add these Broadlink or Bestcon wifi light switches to HA?