Adding device to shelly integration

Hey all,

First Shelly device so go easy :slight_smile:
Read-up and followed the instructions as I can find.
So shelly plug has static ip - can access it from app and web-server.
Shelly cloud disabled - all on my 1 local wifi network.
HA doesn’t find it though ( shelly integration installed )
On the shelly should MQTT be enabled? ( have tried this with broker and HA user/password ) but always says disconnected.
Shelly online log shows connection as 256 - so assume -1 i.e. error…
Not sure if MQTT is required though.

What else should I check to make it visible to HA?

thanks in advance

edit: shelly on latest firmware

Shelly integration log suggestions device not found …

error 404; not found

HA log looks like a discovery issue…

Error doing job: Exception in callback <_OneTimeListener <coroutine object start_server_discovery at 0x7f34d88b9700>>(<Event homeassistant_start[L]>)

Which Shelly device do you have?
Are you using this integration?


Yes that integration. It’s a Plug plus .
Though it does list as a custom integration…


MQTT isn’t needed. I agree it looks like a problem with discovery

Well ; some more googling and it seems Shelly doesn’t work with Asus Alimesh ( which of course is what I have ).

Disabling CoAP ( as the possible fix goes ) isn’t an option as a get 3 device.
Apparently gen3 don’t use CoAP? - so this is a specific problem with Asus AliMesh? or maybe another unrelated issue?

Not sure what to try now…

ShellyForHass is an older integration that is no longer supported so not sure if your router is the problem or not. Does discovery work for non-Shelly devices?

It was the only integration I could see. Removing it and doing add-integration just brings in the same thing. It is listed as a ‘custom’ integration…
Discovery of none shelly things is fine.

Ok. There is a known issue with trying to remove ShellyForHass and use the new integration instead. Search the forum for posts from people that ran into this issue.

1 Like

Somehow HACs shelly integration got added. I removed this, rebooted, then added the integration from the main page ( not HACs ) and indeed device discovery worked!
Shelly HACs ‘version’ should really be removed from HACs - it’s not obvious which one you have installed and HACs one is no longer required…

But! - thank you for all the help. All suggestions always welcome!!

This isn’t true.

Plus Plug S is a gen2 device, gen2 devices don’t use COAP.

This means that the custom component is installed. Core Shelly integration will be available when you get rid of the custom one.

I know all this now :blush:
Removing the hac’s version would avoid this issue .

1 Like