Adding new integration FAILED - help a newbie!

Hello, first post… I am very new to HA but I already started following the rabbit to see how deep is the hole :wink:
So i am trying to add a custom integration by following a guide on GitHub. This one:

I have my server set up in the virtual machine on my old MacbookPro and it works ok - i have my electric meter wifi thingy set up and it is showing everything in HA i am also getting in its native app. So 100% satisfaction here. Now it is time to add a solar inverter (PV) readouts to HA to have it all in one place. And yeah, that seems to be problematic for me.

The guide says to copy files to a config directory in my HA folder (i understand it as where configuration.yaml is located - am i RIGHT?). Since it is a hidden folder on MAC i can access it via Terminal but pasting a folder with necessary files (custom_components) in this very directory brings no effect. In the HA GUI i can’t find the newly set up integration. The path is something like

What am I doing wrong? I have reset the server from Configuration/Server and i have also restarted the VM under macOS.

Hi there,The easiest method for installation would be to use HACS, Is there any reason why you haven’t tried that method?

I have already sorted out the problem. With a help of someone more competent in being a #hackerman :wink:

Turns out that the folder structure where i tried to place custom_components folder was a junk left over from a failed installation attempt from while ago. I was able to access a virtual machine, where HA server sits, via SSH from my main PC and simply add the HACS folder by following the method described in the link you have attached.

Cheers :slight_smile:

1 Like