Adding new zigbee routers - how to best rebuild my network

Like a lot of people, I’ve struggled with the stability of my Zigbee network. I’ve got a Conbee II coordinator and a handful of routers along with a bunch of Aqara sensors connected via ZHA. It’s been a constant struggle to keep the Aqara sensors connected.

I’ve done a bunch of reading here and have formulated a plan around how to fix things when I deploy a bunch of new routers this weekend:

  • I bought a handful of Embrighton light switches and some Sonoff wall plugs to use as routers to increase the density of routers
  • Because I’ll have to reset a bunch, I’m thinking I’ll take the opportunity to switch from ZHA to zigbee2mqtt since it seems some have had better luck the way
  • I’m going to decrease the power of my coordinator (Conbee II) and re-add routers in order of their distance to the coordinator. I’ll then reset the sensors and hope they connect to a more logical router.

I’ve not seen a strong agreement on whether the order in which you pair devices matters. But in my experience, I’ve not seen the network rearrange itself logically when I add new devices. Thus my plan to re-pair the sensors, which I felt was a good opening to migrate to zigbee2mqtt.

If I’m overcomplicating it, I’m all ears. I’m really not looking forward to repairing automations and everything as I re-add these sensors.

This is my current Zigbee map, from ZHA. These mostly all connected, so I have no idea why half of them don’t show a connection. The rest of it makes about as much sense, with the connections not making logical sense based on location of routers.

Sounds like a good plan to me. Particularly the order in which you plan to pair.

If you want to force a sensor to connect to a nearby router, in Zigbee2mqtt you can “permit join xxxx” instead of “permit join all” where xxxx is the nearby router.


Well, I added 6 new routers, migrated to z2m and paired the routers in order of proximity.

I added the sensors, and they were connected for a bit. But now most of them have fallen off, according to the map. The map doesn’t fully agree with the data I’m seeing in HA though. Some of the sensors the map shows as not connected are actually reporting.

Kind of disappointed! Are there known issues with the z2m network mapping?

Try re-pairing the ones that show no connection. Use “Permit All”.

I’ll give it a shot, but that’s what I did when I set them up a few days back, so I don’t have high hopes it’ll work long-term.

The weird thing is that some of the sensors that show no connection in that chart are actually reporting data to HA.

Oh ok then try only permitting them to join the nearest router.

1 Like

I have the same thing with sensors, I think it is due to them being battery powered and sleeping.

I suggest turning on availability in the zigbee2mqqt settings, this allows you to see if something is actually considered offline.

Thanks for the tip @iscraigh ! I Assume this must be a drain on the battery, since it’s not on by default? In any case, I was wondering why I couldn’t see the status, and this is really helpful.

Availability here corresponds to which sensors are actually providing data to HA. That’s a much nicer way to see at a glance which are working!

But it’s still odd to me that the network map doesn’t match up. I guess it must look for very near-term availability, so sensors that don’t report in often may show in up the ‘devices’ list, but not on the map?

The signal strength, and decisions the network makes for how to connect don’t really make sense. I have sensors that are a few feet away from a router that show a horrible RSSI. Then I have others that are quite far, that show a very strong signal. And generally, unless I force them to a specific router, they don’t connect to the nearby routers. I assume this is partially differences in my equipment, but I just have a bunch of Sonoff outlets and Embrighten switches along with Aqara sensors.

Anyway, hopefully I’m getting there. Thanks all!

It happens also for me. Looks like if the sensor reported a long time ago (because not needed to report more often), it is shown as disconnected even if it reports periodically.

Just to add another experience: I’m on ZHA with a tasmota flashed sonoff zigbee bridge. The majority of my devices connect via WIFI, but I recently started to add some door and motion sensors and some kept becoming unavailable. Yesterday I added a cheap zigbee socket (6 bucks on aliexpress) and I basically wanted to see what happens if I do nothing and wait. And a pretty cool thing did happen: With a bit of patience the network just improves itself without needing to do anything. It seems after a couple of hours (can’t tell exactly, let’s say around 5-10) the coordinator seems to see the new router as permanent and devices that kept becoming unavailable just start connecting via the router. I saw multiple posts saying you have to re-pair but if you just wait long enough you seem to actually not have to :slight_smile:

1 Like

It depends which version of the zigbee stack your end devices use. Zigbee 1.2 devices will not re-route without manually re-pairing. Zigbee 3.0 devices will.