Adding the Aeotech recessed door sensor

I have a Aeotech recessed door sensor which shows up fine in HA but always shows as ON. According to this, I need to switch the sensor from Basic Set to Sensor Binary Reporting. I tried using the zwave set_config_parameter service calls with the following which just causes HA to stop:

   "node_id": 38,
   "parameter": 121,
   "value": 16

Items logged after I call set_config_parameter:

16-10-24 21:31:09 homeassistant.components.http: Serving /dev-service to (auth: False)
16-10-24 21:31:09 homeassistant.components.http: Serving /api/bootstrap to (auth: True)
16-10-24 21:31:09 homeassistant.components.http: Serving /api/stream to (auth: True)
16-10-24 21:31:16 homeassistant.components.http: Serving /api/services/zwave/set_config_parameter to (auth: True)
16-10-24 21:31:16 homeassistant.core: Bus:Handling <Event call_service[L]: service_data=parameter=121, value=16, node_id=38, service=set_config_parameter, service_call_id=1977315728-5, domain=zwave>

I did mine through OZW. Then setup a little sensor template to give me the codes I wanted (thanks to help here).

- platform: template
      value_template: '{% if is_state("sensor.frontd_alarm_level_5_1", "0") %}Closed{% else %}Open{% endif %}'
      friendly_name: 'FD'
      value_template: '{% if is_state("sensor.backd_alarm_level_7_1", "0") %}Closed{% else %}Open{% endif %}'
      friendly_name: 'BD'
      value_template: '{% if is_state("sensor.garaged_alarm_level_6_1", "0") %}Closed{% else %}Open{% endif %}'
      friendly_name: 'GD'

Thanks - I tried that originally but maybe I was doing something wrong. Can you walk me through the steps?

I assume you have OZW working properly, if not here is the link I used:

After that, set the zwave network (mine is an Aeon Z stick) to add node. At this time put the door sensor in active/pairing mode. Since it is battery operated it will try to sleep. I believe I kept tapping the button occasionally to keep it awake.

Once it was added (but still awake) you can change the configuration (at the bottom part of the screen) from Basic to Binary.

Anyone else feel free to jump in if I’m butchering this.

I change the report type to Sensor Binary Report, hit submit, and even click Save on the backup controller. It just changes back to “Basic Set”.

Did you click “save” at the top right?

Also, the configuration may be saving to a different location than where HASS is reading from. I had to set up a symbolic link so when I worked in one file it updated both locations. I’m not at my setup right now but will try to find the locations for you later. Or search here as I am sure that is where I found it in the first place.

I did - clicked on the save button in the top right of the page

After changing the setting in OZW you need to push the button on the device. Waking it up with the magnet is not enough. You will see the setting ‘sticks’ then (then hit save)

I thought I read somewhere to open/close it 3 times in (relatively quick) succession if it is already installed. This temporarily wakes it. I must have done something when I installed mine because both batteries are down to 80% after about 90 days.

No good, still am not able to switch it to sensor binary report