Adding Voice to the Smart Home (Home Assistant Style)

Here’s a high level write up on my Home Assistant Speech, notification and music set up.


Looks amazing.

Maybe you can help out us noobs with your config’s.

1 Like

My repo is all public. Hopefully it helps other people…

All my configs and write ups can be found here :

Great, thanks.

I was poking around your repo last week and trying to figure out how you have eveything set up for voice notifications. (Mainly because i wanted the ‘last message’ to display on my floorplan as well, clever use of mqtt btw)

I think i get the gist of it, with automations triggering the speech engine as well as some inherent smarts within the speech engine (ie good morning, good evening, etc), but logically can you break out how you organized the whole thing?

Like if you want to add something at this point, do you typically just create an automation and send it to the speech engine/speech processing scripts? It made me start looking into jinja templating and then i got lost :persevere:

Also got lost with all the input booleans!

It’s probably a bit tricky since it’s just layered and layered in… BUT, for the most part, I have tried to add macros into the speech engine… like this :
and trigger code

I then call the script via an automation like this :

The automations themselves get triggered via sensors, or events or input_booleans.
The input booleans are used for the voice control. Alexa, turn on <input_boolean>.

Hope that helps out.

So cool and thanks for sharing. I don’t really understand macros and the ‘call window check : 1’ but I will look into it. I am guessing its a shorthand way of throwing all automations into the speech engine quickly.

Hey, any idea why I keep getting the following error when the automations run?

2017-08-03 18:36:20 ERROR (MainThread) [homeassistant.components.tts] Can't write 0773d8e925e1b0dbde46306713f24f482ab63b3a_en-us_1128158424_amazon_polly.mp3

seems like permission or storage issue.

Permission, meaning?

Storage is definitely not an issue.

Hass can’t write to the cache directory… I wouldn’t know how to resolve it though. :frowning: My install runs as root.

Seems to only be an issue with amazon_polly, google automation’s isn’t generating those errors.

So, I switched back to google and it’s generating the same error.

Anyone have any idea what mite be causing this or how I can troubleshoot?

Any idea what happens if two automation’s fire simultaneously?