Addon testing with VSCode and devcontainer failed to start HA


I tried the approach described in Local Addon Testing.

  • First I started " ‘Rebuild and Reopen in Container’" → container started successfully
  • I got the root prompt.
  • Then I executed “Start Home Assistant” from Command Panel
  • It was hanging, so I stopped it and tried again.
  • It was starting HA and wrote log files
  • Then it hung and finally wrote the following to the log:

23-10-19 17:15:18 ERROR (SyncWorker_1) [supervisor.docker.manager] Can't start homeassistant: 500 Server Error for http+docker://localhost/v1.43/containers/4140fe2ed251abe1128fc516ffc87b8c2bbfa295e25bbe8560c9819b1320aa33/start: Internal Server Error ("path /tmp/supervisor_data/share is mounted on / but it is not a shared or slave mount"

What can be wrong here?
How can I solve it?

Thank you, Volkmar

I replaced my add on with the “hello world” example. Then HA came up. So, the issue had to do with wrong configuration of my add on.

Good to see you got it sorted. The devs are easier to find on Discord if you have issues in the future: Home Assistant Discord