Addons missing and "Not a valid add-on repository" on any repository url

Tags: #<Tag:0x00007fc4125b7ab0> #<Tag:0x00007fc4125b79e8>

Hi all, I was looking for Xiaomi gateway addon and couldn’t find it.
In add-on store I did have the community add-ons initially.
Firstly I tried adding the Xiaomi Gateway ( … or … ) repositories via the “Manage add-on repositories” and got the “Not a valid add-on repository”.
I did noticed the repository was present in the “Manage add-on repositories” window.
I tried different repositories links, including … which should work, but same error.
Then, as a test, I deleted the repository from the “Manage add-on repositories” window and tried to re-add but I get the same error “Not a valid add-on repository”
Please note that before I removed the community repository, add-ons from it were installing OK, for example the Visual Studio code and SSH&Web Terminal (not the official Terminal&SSH) are working OK.

The install I have is in virtual box on intel hardware and the log shows as below:

20-10-18 19:54:54 INFO (MainThread) [] Update service information
20-10-18 19:54:55 INFO (MainThread) [] Update local network information
20-10-18 19:55:10 INFO (MainThread) [] Clone add-on repository
20-10-18 19:55:11 ERROR (MainThread) [] Can't clone repository: Cmd('git') failed due to: exit code(128)
  cmdline: git clone --depth=1 --recursive --shallow-submodules -v /data/addons/git/942cda15
  stderr: 'Cloning into '/data/addons/git/942cda15'...
fatal: repository '' not found
/usr/src/supervisor/supervisor/store/ RuntimeWarning: coroutine 'GitRepo._remove' was never awaited
RuntimeWarning: Enable tracemalloc to get the object allocation traceback
20-10-18 19:55:11 ERROR (MainThread) [] Can't load from repository
20-10-18 19:55:11 INFO (MainThread) [] Load add-ons from store: 21 all - 0 new - 0 remove

I did search both forum and web about this but everybody seems to just enable the advanced mode and all good, but I did enable the Advanced Mode already and rebooted it a couple of times.

system info:

System Health
arch	x86_64
chassis	vm
dev	false
docker	true
docker_version	19.03.11
hassio	true
host_os	HassOS 4.14
installation_type	Home Assistant OS
os_name	Linux
os_version	5.4.69
python_version	3.8.5
supervisor	247
timezone	Europe/London
version	0.116.4
virtualenv	false
dashboards	1
mode	auto-gen
resources	0

Thanks :slight_smile:


Take a look at the bug reported here and add to it if you feel it’s the same issue:
Add-ons missing - Official and 3rd party · Issue #2955 · home-assistant/supervisor (