Addons not working after migration from Raspi4 to VM


recently i moved my HA installation from my Raspberry Pi 4 to a VM on my unraid server.
I did so by importing a Backup file from the Raspberry installation.
A lot of the move worked really well, my Zigbee devices needed but they do work.
My installed Addons however do not work. non of them can start.

For a test i removed my “Advanced SSH & Web Terminal” addon and reinstalled it. but this did also not work.

after that i created a new VM without applying the backup file. To verify i installed a Addon - this did work.
Then i applied my backup file again, now the Addons do not start.

is this a known issue? is there somewhere a reference that links addons with my ARM based installation on the Raspberry?
is there a way to fix this, or will i need to re-do my setup on the VM?

thanks your your help.

Try restarting the VM

thank you for the response, but i did try restarting the VM already

Normally a reboot of the computer is required, but since you run a VM…

You can try to restore a backup without the add-ons, and copy the configuration from the add-ons manually.

thank you. i was not aware that i could restore without the addons.
i will give it a try

You need to go through onboarding, then upload your backup, then you can do a partial restore of just HA without add-ons.

thank you for your help.
it worked with a partial restore, now i just have to re-do the setup of my addons.
this saved me a ton of work

1 Like