AdGuard Home couldn't start forwarding DNS server

I am getting this message in AdGuard log. And have no idea how to solve it.
Can someone help please?

[15:12:15] INFO: Starting AdGuard Home server…
2022/12/16 15:12:15.794035 [info] AdGuard Home, version v0.107.17
2022/12/16 15:12:15.794263 [info] AdGuard Home updates are disabled
2022/12/16 15:12:15.801164 [info] tls: using default ciphers
2022/12/16 15:12:15.806849 [error] creating dhcpv4 srv: dhcpv4: invalid IP is not an IPv4 address
2022/12/16 15:12:15.828166 [info] Initializing auth module: /data/adguard/data/sessions.db
2022/12/16 15:12:15.828783 [info] auth: initialized. users:0 sessions:0
2022/12/16 15:12:15.828910 [info] web: initializing
2022/12/16 15:12:15.946544 [info] DNS cache is enabled
2022/12/16 15:12:15.946836 [info] MaxGoroutines is set to 300
2022/12/16 15:12:15.947484 [info] AdGuard Home is available at the following addresses:
2022/12/16 15:12:15.947942 [info] Go to
2022/12/16 15:12:18.022439 [info] Starting the DNS proxy server
2022/12/16 15:12:18.022645 [info] Ratelimit is enabled and set to 20 rps
2022/12/16 15:12:18.022671 [info] The server is configured to refuse ANY requests
2022/12/16 15:12:18.022684 [info] DNS cache is enabled
2022/12/16 15:12:18.022705 [info] MaxGoroutines is set to 300
2022/12/16 15:12:18.022737 [info] Creating the UDP server socket
2022/12/16 15:12:18.022945 [info] Listening to udp://
2022/12/16 15:12:18.022968 [info] Creating the UDP server socket
2022/12/16 15:12:18.028975 [fatal] couldn’t start forwarding DNS server: listening to udp socket: listen udp bind: address already in use


The error
2022/12/16 15:12:18.028975 [fatal] couldn’t start forwarding DNS server: listening to udp socket: listen udp bind: address already in use

Means that you already have a service running on port 53
I will have a look at the adguard install instructions for home assistant, but usually what you would do is move an existing dns service to say port 5353 so that adguard dns service can run on port 53

There maybe someone on here more familiar with the adguard integration with home assistant, but hope maybe this helps you move forward

Okay so I looked at the install instructions of adguard on hassio, and it’s just an addon that installs adguard to port 53. I have experience with adguard and other dns configurations,
so I would ask have you recently updated adguard? Have you recently changed the adguard configuration?
Do you have a last known working backup of hassio that you can revert back to?

what version of hass and version of adguard addon version are you running?,
I saw some articles referring to some similar issue and error. I didn’t find any solid answer as the users reverted to backup to resolve it

I have got the same behavior after upgrading to 4.8.0.

 Add-on: AdGuard Home
 Network-wide ads & trackers blocking DNS server
 Add-on version: 4.8.0
 You are running the latest version of this add-on.
 System: Debian GNU/Linux 11 (bullseye)  (aarch64 / qemuarm-64)
 Home Assistant Core: 2023.1.6
 Home Assistant Supervisor: 2022.12.1

I also have this issue. Wondering if it is realated to this change in 4.8:

Am too busy now to diagnose myself, and have rolled back to previous backup.

Hi all, I have similar problems after upgrading to 4.8.3, moreover the addon keeps crashing with continuous restarts from the watchdog which inevitably fail. I reverted to the previous version (4.7.5) and all is good again. No definite news so far?

I’ve been checking the release notes for each upgrade, but skipping installs as I haven’t had time to investigate, and nothing to indicate it’s been fixed (or changed)

@farnsy, thank you for the fast reply … let’s wait, hopefully a working upgrade will come soon. I prize this addon very much. By the way I wonder, considering the important issue, why there are so few people complaining …

FYI I just tried updating to 4.8.4 and still get the same error

2023/04/08 10:56:16.397499 [fatal] couldn't start forwarding DNS server: listening to udp socket: listen udp bind: address already in use

I’ve seen some people be able to get it working by enabling IPv6.

edit: ignore this.

I’m still getting this on every release. Just wondering if anyone has any tips on how to get around this - would like to run most up to date if possible…

Also curious as to what is different in my configuration that I’m impacted by this and many others aren’t…