ADS Beckhoff configuration, I cannot get it working?


#1

Hi,
I am newbie with the Home Assistant and I would like to have some help.

I have Beckhoff autoamation system in my house running TwinCAT version 2. I tried to configure ADS to work with the system, but I am not able to.

I have configured configuration.yaml file like this

ads:
device: ‘55.345.3.2.1.1’
port: 801
ip_address: 192.168.8.100

When I restart the system, it gives me error that there is something wrong with the configuration. Validation of the configuration.yaml is ok.

I have checked values from the TwinCAT program running on my laptop. And I am able to connet to Beckhoff system with my laptop.

What else I have to configure to get Beckhoff system working?


#2

In TwinCat you have to add route to home assistant.


#3

Whats HA ams id? HA ipr.1.1?


#4

Yes.
It worked for me some time ago, Now I have problems to connect and I don’t have enought time to contrive solution :wink:


#5

How did you add the route? In the XML file or did HA pop up in twincat (broadcast search)?


#6

There is many ways to do this: in device manager, xml file, in twincat - routes, using cerhost and TcAmsRemoteMgr. Last time I connected without any issues, today after many attemps I reinstalled HA and it is ok.


#7

Are you using hassio? Mine crashes. And i guess HA should pop up when you do a broadcast search in twincat? I tried to add in the xml file but without success

Error during setup of component ads
Traceback (most recent call last):
File “/usr/local/lib/python3.6/site-packages/homeassistant/setup.py”, line 148, in _async_setup_component
component.setup, hass, processed_config) # type: ignore
File “/usr/local/lib/python3.6/concurrent/futures/thread.py”, line 56, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.6/site-packages/homeassistant/components/ads/ init .py”, line 57, in setup
import pyads
File “/usr/local/lib/python3.6/site-packages/pyads/ init .py”, line 5, in
from .ads import open_port, close_port, get_local_address, read_state,
File “/usr/local/lib/python3.6/site-packages/pyads/ads.py”, line 23, in
from .pyads_ex import (
File “/usr/local/lib/python3.6/site-packages/pyads/pyads_ex.py”, line 46, in
_adsDLL = ctypes.CDLL(adslib)
File “/usr/local/lib/python3.6/ctypes/ init .py”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: Error loading shared library /usr/local/lib/python3.6/site-packages/pyads/adslib.so: Exec format error

This is my setup

    # ADS
    ads:
     device: '192.168.10.xx.1.1'
     port: 851
     ip_address: 192.168.10.xx

#8

Hello. I am using home assistant on synology using docker.
I don’t see HA in broadcast search. I added staric route to HA.
In my case problem was that I didn’t select “Use same network as Docker Host”
Your config looks ok, I am not using Ip_address option.


#9

Same problem here.
I’ve added a static route in the Beckhoff PLC, and added the ads: config to the configuration file.
Do I need to install something on Home Assistant?

As I look into the logs i receive the following error:
019-01-12 00:57:43 ERROR (MainThread) [homeassistant.setup] Error during setup of component ads