ADS component v0.6

when adding the ads component i got the next error:
OSError: Error loading shared library /usr/lib/python3.6/site-packages/pyads/ Exec format error

Does any one have an idea

I have the same problem when adding the ads-component.
I use on a raspberry Pi 3.

Anybody an idea what the problem is?

I have no errors but also still no values.
I made an ams route from the TwinCat2 PLC to the PI, but still no result.
How can i test the ads connection ?

how did you get rid of the above error? I still have the error from your first post here…

I first used the image now i used hasbian image.

Yes, with hasbian I got it linked without error. But I don’t get how to define the light correctly. In my TwinCat there is a LightSample with the boolean WebOn and i have a variable for my living room light called .LivingRoomLight

How do I define that correctly? It should use the ADS variable .LivingRoomLight to set the boolean WebOn if i want to set the light on…

The ads communication is working with TwinCAT 2 and with TwinCAT 3.

I am using TwinCat2

Hi guys,

Also trying to use the ADS component on HassIO. Should this work?

My first attempts with the ADS component were on a windows system with Twincat installed on it. This was succesfull. All functions I tested worked immediately.
No with the HassIo on a raspberry pi it doesn’t seem to work.
Any suggestions?