Advanced SSH & Web Terminal init fail

The Advanced SSH & Web Terminal is failing to start :frowning: it was working before and I can’t figure out what is wrong with init commands. Any suggest?

The Log:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting
 Add-on: Advanced SSH & Web Terminal
 A supercharged SSH & Web Terminal access to your Home Assistant instance
 Add-on version: 15.0.3
 You are running the latest version of this add-on.
 System: Home Assistant OS 10.3  (aarch64 / raspberrypi3-64)
 Home Assistant Core: 2023.6.2
 Home Assistant Supervisor: 2023.07.1
 Please, share the above information when looking for help
 or support in, e.g., GitHub, forums or the Discord chat.
s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service init-user: starting
s6-rc: info: service init-ssh: starting
s6-rc: info: service init-mysql: starting
s6-rc: info: service init-mosquitto: starting
s6-rc: info: service init-docker: starting
[09:55:35] INFO: Docker support has been enabled.
s6-rc: info: service init-docker successfully started
s6-rc: info: service init-mysql successfully started
[09:55:37] NOTICE: Session sharing has been disabled!
swapon: /backup/_swap.swap: Resource busy
[09:55:39] FATAL: Failed executing init command: if [ ! -f /backup/_swap.swap ]; then fallocate -l 2G /backup/_swap.swap {MESSAGE}{MESSAGE} mkswap /backup/_swap.swap {MESSAGE}{MESSAGE} chmod 0600 /backup/_swap.swap {MESSAGE}{MESSAGE} swapon /backup/_swap.swap {MESSAGE}{MESSAGE} echo SWAP_NEW_FILE_CREATED_USED ; elif [[ ! $(dmesg|grep _swap.swap) = *swap\ on* ]] ; then swapon /backup/_swap.swap {MESSAGE}{MESSAGE} echo SWAP_USING_OLD_FILE ; else swapoff /backup/_swap.swap {MESSAGE}{MESSAGE} swapon /backup/_swap.swap {MESSAGE}{MESSAGE} echo SWAP_FINAL_ELSE_STATEMENT ; fi
s6-rc: warning: unable to start service init-user: command exited 1

Thanks in advance!

Looks like you abused the SSH addon to increase the available swap space, for whatever reason?
Well, it fails…

How to increase the swap file size on Home Assistant OS - Installation / Home Assistant OS - Home Assistant Community (

@koying most people have a reason for increasing their swap space. Usually with many integrations, the default swap of HAOS does not suffice.

@knorst please post stuff like this in my thread for quicker help. The simple answer is the error clearly tells you what the problem is. Resource busy means take a reboot so it’s no longer busy. Secondly, you can try removing the entire INIT_COMMANDS line, take a reboot, DELETE that file and try again. Good luck!

I won’t enter that debate, but it’s more problematic when people forget or don’t realize that trick causes issues, like in this instance :wink:

Definitely won’t argue that… it’s obviously a workaround and I’m way more interested in an official way of controlling this. Sadly, the problem hasn’t gotten as much attention as it deserves. Older RPi 3 will choke running HAOS without this modification — having said that, even my virtual HAOS struggled with speed and crashes until this was introduced.