Aeotec 7 series Z wave Switch not reporting current nor power

Hey team! I wasn’t sure whether to post this in Hardware or Configuration. So please move it if I posted it in the wrong place.

I setup this Aeotec 7 securely (successfully paired securely to my Z wave network) yesterday.

It shows voltage, and I can control it from HA, but it always shows 0 for amperage and power even when the espresso machine is turned on.

Anyone have any ideas here?

Thank you so much in advance.


I would check your Z-Wave configuration on that device to see if the trigger for reporting power is too high. You might also be trying to push too much power through that, I have other brands that go haywire if you push the wattage too high, they aren’t built for that kind of juice. I’ve found that for anything over 300W or so I have to use a heavy duty outdoor style adapter rather than those little outlet switches. On mine it also shows if there is a fault because of overloading the device, you can see if that is getting triggered. You’re lucky, if I go over the capabilities of the adapter it usually powers off!

1 Like

Thank you! I will check that and report back here.

1 Like

I presume that you have a Smart Switch 7. Yes, you’ll need to check the configurations to see what it takes to report power, current, energy, etc. Its usually based on some amount of change, and/or periodically. I have a Smart Switch 7 (U.S.) and looking at its config, by default it does not send a report based on change in power. It does send power readings automatically, but every 600seconds, so its possible the switch is not seeing any power consumed at reporting time.

1 Like

I ended up figuring this out, exactly was @wmaker said, basically tuning 2 options on the device through HA app, to set the threshold and reporting frequency for current. Working a charm now.