Aeotec Dual Nano switch in HASS

Hi All,

Does anyone have any experience with the Aeotec Dual Nano switch in Hass?

I have successfully added this to HASS, however it’s only showing a single Switch component. It’s meant to be able to control 2 switches individually. Instead I get a single switch that control both lights at the same time.


Hi @Kanishkaz, I run two of these in my house and they do show up. If you goto the developer tools > states and search for the switch you should find three entries for the same switch


The first two will relate to the physical switch. The third can be used to turn the first two on and off.


Edit: just noticed you said nano. The above relates to the GEN5 dual switch, not sure if it will be the same with the nano


Thanks for checking.

Yeah, I think the Nano switch is still very new. So I’m not sure if the OpenZwave config is up to date for this device. I’ve tried removing and adding this a couple of times now. It only shows one switch.


I’ve got the opposite problem. I see six switch entries. I am having trouble working out which one is actually controlling the switch and there is a lot of lag in updating the HASSIO interface. Anyone else using these?

Did you ever get this solved? I just installed a set of Dual nanos and I am having the same problem. They’re only giving me 1 switch to toggle

Have a look here: Aeotec Dual Nano Switch