Aeotec Gen-7 Zwave stick, new firmware 7.21.3, still jammed controller and dead devices

Aeotec / SiliconLab released new firmware for the Gen-7 (700 series) stick.

After two days of testing this new firmware on my Aeotec Gen-7 with 66 devices (40 direct powered, 26 on batteries):

  • still 2 jammed controller occurrences each day.
  • still “dead” devices, a few per day, lights not switching, not reacting to motion, etc.

In the release notes for 7.21.3, SiliconLab also mentions that the “locked-up controller issue” is still not resolved.

So after months of struggling with the Gen-7, I’ll change to a Gen-5 stick, just bought one, so now I have to transfer NVM data from the Gen-7 to the Gen-5, and hopefully my ZWave problems will be solved then.

I made that exact move around the 7.18 firmware timeframe (Early last year?) and have never looked at a 700 series stick again. My next one will be an 800 based controller IF I need LR capability. (And that’s a big IF). I get the occasional generic zwave weirdness on occasion, but the plague of lockups stopped.

When I made the move, I also went and made sure all my S0 stuff was joined non-secure (unless it was a garage door opener or a lock - old Schlage and a Linear GDO require S0) and tuned down any power reporting devices (Zooz heavy duty switch) to not report more than once every second. All that was to clear the network chatter to give the system it’s best chance. Since then, its been pretty reliable.

I’ve been running on 500 series fine. I bought 2 700 series sticks as I was thinking of upgrading, then saw all the issues. Then I bought 2 800 series sticks, and then saw there was issues with those. At which point I bought several 500 series sticks to make sure I have a viable replacement if the 500 stick fails.

Silicon Labs is not at the top of their game (or maybe they just have no game)

2 Likes

Moved to a Aeotec Gen5+ stick last week, and what a relief!

No jammed controller, no dead nodes, no unresponsive devices.

All working flawlessly for six days now. So just bought a spare gen5+ for backup, and trashed the Gen-7 stick. Should have done this much earlier, but better late than never.

1 Like

Where can i find 7.21.3 firmware ?

Aeotec website

It’s 7.18.8 or 7.20.2 on Aeotec website…

Aeotec website

See bullet point 4, link to 7.21.3 firmware.
But please be aware, software still contains bugs.