Aeotec Home Energy Meter values don't seem to make sense:

It’s supposed to be one value for each leg and a total, The amperage is pretty close but none of the other values are close:

Total: 8.04 Amps
Leg1: 3.48 A
Leg2: 4.55 A

Total: 672.73 W
Leg1: 413.95 W
Leg2: 447.11 W

PreviousReading: 11.3 kWh

Total: 11.32 kWh
Leg1: 0 kWh
Leg2: 0 kWh

Total: 122.57 V
Leg1: 122.5 V
Leg2: 122.51 V

I followed the instructions for connection, the clamp with the arrows facing inward is the line the device is plugged into. The other clamp has the arrow facing street side.

Do you have a picture of your clamps in your breaker panel? It’s tough to see, but you can see the arrow going up on the clamp on the left. The arrow goes down on the right. The one on the right is clamp 1, and the plug goes into a breaker that is fed from the line on the right.

Did you setup the reporting option?

No, this is what came into the HA dashboard by default, do I need to set them manually to work?

Yes, you’ll need to setup the reporting.

Thank you, is there documentation on how to do that? Is that related to the part that says about adding the bits together in the instruction booklet? Where would I make that change in HA?

Left menu > Configuration > Zwave
Select the power meter
Reporting Group 1


See first part of this post :smiley:

Thank you I’ll try that now!

Thanks I think that worked.

Here are the steps I followed for posterity. (Exactly what you said with a tiny bit more detail)
Left menu > Configuration > Zwave
Under nodes I chose the Meter

Under Node config options I chose 101: Group 1 Reports

From there I noticed it said an integer from 2147483648 to 2147483647
I chose 2147483647 and it now seems to be working!

Here is what the sensors look like now:

On a separate note, should I secure those clamps up a bit with tape so they aren’t touching the breaker or each other?

1 Like

They’re fine, plastic doesn’t conduct :wink:
Just FYI depending on what you want to monitor you can separate out the groups and refresh rates.

ie: set the “Previous Reading” sensor to every 24 hours, then you’ll know how much power you used on a 24 hour cycle

Thanks for the help, I’ll read through the options in more detail in a bit. I don’t know what I want to see yet.

1 Like

How do I set the refresh rate???

Configuration > zWave
Select the node from the dropdown
In the Node Config options dropdown look for the 111, 112, 113 group 1 - 3 interval. Set the value.


Remember the time is in seconds, so 86,400 would be 24 hours.

1 Like

I should have been more specific. What I meant was:
How do I set the Refresh Rate for JUST the Previous value(s)???

Use the info on this link to set the reporting:

1 Like

I really messed things up for a while. I followed the above instructions for setting up reporting along with reading the info provided

Before I started I noted that 101 was set to 2, 102 was to 1 and 103 was set to 0. I decided to leave 101-102 as it is and modified 103

I decided I would experiment with just clamps 1-2 for watts and entered 768 info the node config param for report 3 (103)
I changed 113 refresh rate to 300 (5 minutes)
All data was still be updated as usual and my latest changes/additions seemed to have no effect.
I set 103 back to 0, 113 back to 5.

I tried playing around with both 101 and 102 and eventually ALL reporting stopped. I was unable to edit these parameters via the web interface. The minute I changed any of the values for 101 or 102 and save the config, the values would revert back to the original values. Only way I could restore back to what I had before I made any changes was to shut down HASS and edit the xml file manually. Weird thing is though, the Current and Previous KWh are always the same.

1 Like

Thanks, I struggled a while until i found this post. Latest firmware today for European w095-C is 1.06. I can recommend to reach out for aeotec support for instructions and update of firmware. The number you added also includes reseved values so when saved it adjust value to the highest to include all. Even I as newbie on this type of work managed to get it up and running but I am not yet satisfied with report settings.

Hi Fjp,
I’m on the same boat as you. Installed HEM G5, but can’t seem to make the configuraion stick. Sometimes i see the values change, and later on i see them back to stock configuration. I’m running the new openzwave beta implementation. I’m not sure if the changes i do get applied right away (i see the log they are being sent) permanently