Aeotec Home Energy Meter values don't seem to make sense:

Configuration > zWave
Select the node from the dropdown
In the Node Config options dropdown look for the 111, 112, 113 group 1 - 3 interval. Set the value.


Remember the time is in seconds, so 86,400 would be 24 hours.

1 Like

I should have been more specific. What I meant was:
How do I set the Refresh Rate for JUST the Previous value(s)???

Use the info on this link to set the reporting:

1 Like

I really messed things up for a while. I followed the above instructions for setting up reporting along with reading the info provided

Before I started I noted that 101 was set to 2, 102 was to 1 and 103 was set to 0. I decided to leave 101-102 as it is and modified 103

I decided I would experiment with just clamps 1-2 for watts and entered 768 info the node config param for report 3 (103)
I changed 113 refresh rate to 300 (5 minutes)
All data was still be updated as usual and my latest changes/additions seemed to have no effect.
I set 103 back to 0, 113 back to 5.

I tried playing around with both 101 and 102 and eventually ALL reporting stopped. I was unable to edit these parameters via the web interface. The minute I changed any of the values for 101 or 102 and save the config, the values would revert back to the original values. Only way I could restore back to what I had before I made any changes was to shut down HASS and edit the xml file manually. Weird thing is though, the Current and Previous KWh are always the same.

1 Like

Thanks, I struggled a while until i found this post. Latest firmware today for European w095-C is 1.06. I can recommend to reach out for aeotec support for instructions and update of firmware. The number you added also includes reseved values so when saved it adjust value to the highest to include all. Even I as newbie on this type of work managed to get it up and running but I am not yet satisfied with report settings.

Hi Fjp,
I’m on the same boat as you. Installed HEM G5, but can’t seem to make the configuraion stick. Sometimes i see the values change, and later on i see them back to stock configuration. I’m running the new openzwave beta implementation. I’m not sure if the changes i do get applied right away (i see the log they are being sent) permanently

I suffer the same issue with HEM G5 and openZwave. I have changed the parameters using the service of HA, even I have changed the parameters using other tool (simplicity Studio 5), but when I connect it again to HA it works with the parameters for a very short time, I refresh the node info and I see the parameters were changed again to the original config. I am not sure but it seems like openwave changes automatically the parameters…

I have just checked the HEM Gen5 using other Domotic software on my desktop (Domoticz) to verify if the problem comes from HA OpenZwave or from the device, conclusion: The problem comes from the device, I got the same result with Domoticz, several minuts after change the parameter the device returns/reset itselfs to the factory parameters (even changing the parameter 252 ( lock parameters) to 1). I will google a little more and if no success the will write to aeotec support.

Hi Veletax,

I was able to solve this using OpenZwave Control Panel and later on, also using Zwave2MQTT

Hope this helps!


The cause was two things: (Thanks to Aoetec support, they gave me the solution, great support!)
1 - Sometimes pairing using software may try to use Multichannel Association which will assign Node 1 endpoint 1 which the HEM gen5 will not report to properly. I confirm it is the case using Domotiz, but not with HA in my case.
2 - The reset button on th device not perform a “hard reset” or complety only pressing it, it is necesary to disconect the device from grid and connect again after wait 10 seconds at least and then perform the reset pressing the button. ( Recommendation from Aeotec)

So after perform step 2 and reseting the devices pressing the reset button I perform manual paaring unsing the Z-Stick Gen5 ( no with software) it entsures the device adquire the right configuration ( all nodes correctly reported) here again following the instruction of Aeotec. After this, I connected the Z-Stick Gen 5 to the HA, performed a clean installation of ZHA and the device was detecting and run perfect now.

Do you mind posting the screenshot of the config parameters from zwavejs2mqtt for reporting total for group 1?

I have similar problems trying to understand the data from an Aeotec Gen 5 Energy Meter.
I have a three phase meter (three clamps - one for each phase) and have UK 240V system. The CT clamps are installed correctly and generating data.
I have Z-Wave JS installed and the integration Z-Wave JS to MQTT set up correctly.
IN HA Configuration > Integrations > Z-Wave JS shows 2 devices, my Aeotec Gen 5 stick and the Aeotec Gen 5 Meter. It shows 28 entities.
Many of these entities seem to make sense and I do understand the relationship between Amps, kW and kWh, however I do not understand how to manipulate this data into a display that is useful.
I don’t need to know about Volts - this is almost always going to be stable and not something I need to monitor so I can disable those entities.
I want to have a display that shows me the daily total kWh for each phase (so how do I set the accumulation time to 86400 seconds).
I want to have a regularly refreshed (every few minutes or faster) Wattage display for each phase, so when I turn on the kettle for example I should be able to see this draw on the appropriate phase.
I don’t really need anything else - just the currently used wattage for each phase and the daily kWh for each phase. A graph of the daily flow would be nice as well so I can see the impact my solar panels have on the energy flow.

I don’t understand how to set up reporting groups or tie intervals.

I can provide a json dump of my Z-Wave to MQTT setup if this helps.

Hoping somebody has figured this all out and can help get me on the right tracks.


Can’t give you a detailed description, but this is how I have it setup using the same Energy Meter (but with the deprecated Z-Wave integration) to monitor my PV production and Consumption.
I created a utility_meter in configuration.yaml (sensor.node26_energy is the HEM and the first of the power channels, showing the total).

    source: sensor.node26_energy
    cycle: daily

Thanks for your help. The Z-Wave JS to MQTT produces so many entities, many of which simply do not change (or maybe they change if I reboot I need to check), it is incredibly confusing.
Are you using Z-Wave to MQTT as well as the deprecated Z-Wave integration?
I may have a look at what happens if I remove everything and try with the deprecated integration just to see if this makes things clearer.
I do not have a sensor.node26_energy entity.My entities are called things like my first item sensor.home_energy_meter_gen_5_electric_consumed_a - this is showing 1.67A and that value has not changed in days!

I use the “Z-Wave (deprecated)” integration only - I haven’t got any other zwave working, so I can’t help you there, sorry. sensor.node26_energy is how I rename the zwave units and sensor values to make sense. In the old integration this is done by under “Z-Wave Node Management” and then rename the entities.

If your value is static, can you see if you get regular updates from the meter? In the deprecated Z-Wave integration this is done by tailing the logs from the web, once again I don’t know how to do this in another integration. You may need to configure the meter to send values, specially the Group values (parameter 0x101 which I have set to 1794 and parameter 0x103 which I set to 30 seconds reporting interval), see the documentation.

In case you haven’t deleted that, I would start on the default “Overview” dashboard and have a look at all the values from all known sensors.

I am having the exactly same problem. Did you managed to fix it?

I’m using Zwave JS (new version) and the parameters 101/102/103 are toggles to make it easier instead of setting numbers (generated by the sum that we want).

Maybe there’s a problem with the toggles? Are they working? Are they sending the right parameters?

Yes - I am using Z-Wave2MQTT and in the web gui for this integration I am able t enter the parameters which will force the HEM to output the values I require. I have set it to give me the kWh total and for each phase, and then also the instant kW total and foreach phase. The parameters to enter must be calculated using Aeotec’s spreadsheet.
Aeotec support did actually give me the parameters to enter, but I had to work out for myself in which boxes these should be entered in the web gui.
Parameter 101 [4 byte] = 4144911
Parameter 111 [4 byte] = 30
Notice that Aeotec refer to “Parameter 101” but in the web gui this is shown as entry box “[2-112-0-101] Report Group 1”.
In fact after working out ow the Aeotec spreadsheet works, I decided to use the value 16131 in this box.
One final mystery I needed to work out was how to reset the accumulated kWh values - in my case I wanted to reset the numbers to zero every 24 hours. You canread how I was helped to get the solution in this thread: Z-Wave JS - how to reset accumulated values - #2 by TeaTimeSoon

Hi guys,

i’m having problem pairing my HEM Gen5 with HA.

I use a Aeotec Z-Stick Gen 5 and Z-Wave JS.

I had an electrician install my HEM Gen5 permanently so i can’t break the power.

Puting my Z-Wave JS in Node adding mode and pressing HEM Gen5 button once starts connecting showing Device/Node info but i hang there. No node info and closing adding guide and looking in Node list i just get like Node 30 not ready.

How can i ad my HEM Gen5 to my Z-Wave network?

I have the same problem. It would seem that everything else is working, but the production is not updated :sleepy: