Aeotec Multisensor Firmwareupdate via ZWave JS stuck at 99%

Hi Forum,

found information that the Aetec Sensor could be updated with 1 click via Update Panel. So chosed 1 but the upgrade got stuck at 99%

z-Wave Panel is happy however

I am hesitant to restart HASSIO … let me know what you think


How long have you waited? There was someone else who posted about this update taking a significant amount of time (hours)

I have half a dozen of these, and it has been a lot quicker and does not get stuck if you can at all move them closer to the dongle. I am putting them next door to the dongle on a temp cable they take under 5 minutes to update, then do a quick re-interview before you put them back. If it gets stuck a reboot the 3rd option will reset them so you can try again. I waited 4 hours before I tried other stuff.

Ok. i was quite optimistic as the progress bar was moving forward … so i guess the progress is not mesured but just some static thing to keep the user entertained.

I’ve waited 3-4h so far, willl wait until the evening and move the device closer to the dongle.

I will try your suggestions with the other 3 devices left

Excellent, let me know how you get on, I’ve just done the last one, plus 3 range extenders they all seem to be working fine. Good luck

1 Like

I’ve been prompted for update on 3 Z-wave devices. One went fine (but took an hour or so). Another one of same device type hung at 11% for multiple hours, and has not been restart-able; now says “Update already in progress” (and update can’t be aborted). Can’t move those near the Z-wave controller, because they’re wall switches. Third device just hung for really long time, without any progress % indication. Tried moving it next to Z-wave stick; no change.

So I had one device updated OK; two are a mess.

I ended with buying a second Zwave dongle just for firmware updates. Had the same issue with Aeotec multisensors, they never got to finish an update, when being a part of the mesh.
But updating them with the second dongle on my PC with SiliconLabs software went flawlessly.

so this morning i found the MultiSensor to be updated to 1.17 OK. However had to restat HASSIO to reflect the new FW Version. Doing the others step by steps as there was no battery drain during upgrade

HI TIm, I had a similar issue, try re-interviewing the device then a full reboot. That worked with me I was able to re-try the update.

1 Like

@itnassol - Thank you SO much for that advice, to perform “Re-interview device”. That worked excellently to upgrade both of my problematic devices from HASS UI.

I did not have to do a reboot. But did discover (or finally remember :slight_smile: ) that the battery-operated device needed to be waked up. It looked like it needed waking up for the Re-interview, and for the firmware update, and once again during the firmware update when it appeared to stall out.

Just FYI, the battery operated device only took about 10-15 minutes (and was sitting right next to the Z-Wave hub). The mains-powered device required about 30 minutes --but it’s in another building, reachable only thru a pair of Z-Wave Range Extender devices acting as a bridge.

That’s excellent news Tim, so nice when things come together, maybe you could mark that as a solution for me when you get 5 minutes. Have a good weekend.

@itnassol - Yes, I had already tried to mark it as solution, but realized I cannot, apparently because I was not the original poster. Thank you so much for the solution.

@px80 - Can you try that approach (Re-interview the device, then retry the firmware update). If it works as well for you as it did for me, could you mark @itnassol’s reply as Solution. Thanks.

marked as resolved. had no issue with the other 3 motion sensor

1 Like