Aeotec Multisensor Luminance

Hi all, quick question that I haven’t found an answer for in the forums.

Is it possible to change the reaction time of different measurements on the Aeotec Multisensor 6?

I’d like to use the motion to trigger an automation to turn on a light, but only if the main light isn’t on already or its bright enough (based on Lux).


Hi @Marauder2,

Try this. Actually for the binary sensor you might have problems if it is not changing state (so that it sends two different codes, one for motion detected and the other for off) and might need to use the sensor with burglar suffix instead.

- alias: test
  initial_state: 'on'
    - platform: state
      to: 'on'
    condition: or
      - condition: state
        entity_id: light.bbb
        state: 'off'
      - condition: numeric_state
        entity_id: sensor.ccc
        below: 'ddd'
      - service: light.turn_on
        entity_id: light.eee

Hi @Petrica, I am able to make an automation that uses the burglar entity successfully and the motion does update quickly.

I’m trying to turn on a Hue Go when motion is detected but only if the upstairs light isn’t already on. The upstairs light I have isn’t connected to HASS so I can’t use its state as a condition, so I thought of using the Luminance measurement from the sensor and have a condition of Lux being below a certain value. My problem is that the Luminance measurement is really slow to change so the light could be on but the Lux not update in time, and the automation would trigger on motion.

Thanks for your help!


Try modifying Config parameter 22: Illumination Differential Report (it should report luminance percentage each minute). I think it should be the same parameter on your sensor.

If you need an instant update I recommend getting a NodeMCU and a LDR with this project:


There’s a limit to how fast it will update if you’re running it on battery power, but otherwise you can change a range of settings in the control panel.

@Tinkerer and @Petrica thanks for your help.

I got it to work. I changed “43: Threshold change in Luminance to induce an automatic report” but it still wasn’t changing, needed to set “40: selective reporting” to 1 (enabled) and then it worked. 40 is defaulted to disabled so it only updates every 59 minutes (read online), but because I am on usb power I can enable it.