Aeotec Nano Switch Problem

Trigger warning; this is going to be a long one, but context is key.

About 16 months ago I was fortunate enough to be able to upgrade my bathroom. One long standing issue I had was that my austistic son would always forget to turn off the lights in the bathroom, which of course in turn kept the extractor fan running. The bathroom is right next to our bedroom, so of course this disturbed our already distured sleep. I planned to insert a smart switch into the extractor fan isolater switch so that I could control this switch via home assistant. I had some smart GU10 recessed lights in the bathroom, covered the bathroom light switch with an aftermarket cover and added a light remote on top of that. Obviously the light “switch” had to be on all the time for the smart lights to work, and the fan would need to be triggered by other means. I got a humidity sensor, and this turned the fan on with the morning shower routine and all worked wonderfully. I used a couple of spare buttons on the light remote to manually turn the fan off just in case, but never between the hours of 21:00 and 06:00. It all worked wonderfully and I slept well in my bed.

…until a few months ago. The extractor fan switch started to show as unavailable periodically. I’d re-interview in Z-Wave and it would come back online. Then this started to fail more regularly. I started to reload the Z-Wave integration which would sometimes work. I’d flip the physical isolator switch which would sometimes work. But over the last few weeks nothing has worked and the switch has remained unavailable for more of the time it’s been unavailable. I’ve tried everything I can think of to troubleshoot this issue (which I will detail later for those kind souls who are still reading) but I’m pretty much ready to throw in the towel on this one. So for anyone who has a similar scenario I would really appreciate to know how you have gone about solving this problem, and what your experience was. I see two alternatives here;

  1. Replace the Z-Wave Aeotec Nano Switch with a like for like Zigbee device. The vast majority of devices in my smart home are Zigbee rather than Z-Wave (52 devices versus 4 devices). However the Zigbee devices are all that little bit larger and I have a relatively new build UK house with small back boxes and the Zigbee only just fits. I also risk running into the same problem with my Zigbee network, although this has proved far more reliable in the many years I have been running home assistant.

  2. Completely ditch the smart switch in the extractor fan isolater and get a smart physical switch for the lights. This way I have the extractor fan coming on with the lights, but at least I can have the lights turning off automatically after a period when my son inevitably forgets.

Any real life experience of how other people have solved this problem would be gratefully recieved. To me, this is one of the headline problems that smart homes solve, so there’s probably even more options than I have considered.

I’d totally ditch Z-Wave completely, but I have a Conexis L1 which has worked flawlessly for years with the Z-Wave module in it, and with the changes in the Yale support, they can prise the Z-Wave module from ny cold dead hands.

As promised, here’s what I’ve tried ();

  • USB extension leads (always had these, right from the start and the Zigbee and Z-Wave USB controllers both go in different directions to each other as far as the extension leads allow)

  • switching USB extension leads, i.e. using the one that works with Zigbee and using that for the Z-Wave

  • healing the Z-Wave network

  • remove the Aeotec Nano Switch and including it again

  • factory resetting the Aeotec Nano Switch and including it again

  • factory resetting the Z-Wave USB controller and reinstalling the Z-Wave integration

  • switching to Z-Wave JS UI and looking in the logs for anything meaningful (although I have no idea what that might be)

  • trying to add the switch in secure mode. This would not work, despite being advertised as possible on the device.


  • Zooz USB 700 Series Z-Wave Plus S2 Stick ZST10 700 - EU/UK

  • Aeotec ZW116 Nano Switch with Power Metering - Z-Wave Plus (No Security)

  • Shenzhen Neo Electronics Co., Ltd. Motion Sensor NAS-PD03Z (No Security)

  • Yale Conexis L1 Door Lock (S2 Authenticated)

  • Fibaro Wall Plug FGWPG-111 (S2 Authenticated) ← I only bought this after I stared to have problems in the blind hope that a permantently on device may help the mesh

For those who have go this far, may all your smart home woes be solved with a reboot…

There’s multiple things to look at.

a) computer capacity - if its limited in RAM that can cause these sorts of issues. What’s it running on?
b) zwave mesh - you only have two mains powered devices, this may not be enough to provide alternative routes when one fails
c) power meters can spam the zwave network. Are the RX/TX stats high for anyone device.

Thanks for the reply.

  1. Raspberry Pi4 - 4GB of RAM. I don’t monitor it, but I’ve never seen it above 50%. I will see if I can monitor it though.
  2. I suspected this may be an issue, but I am not really open to the idea of increasing my Z-Wave devices given that I mostly have Zigbee and these work pretty much flawlessly. However the other devices never seem to fail or have issues. Maybe this is again something I can monitor (the debug logs I have been collecting don’t see to indicate any issues; other than with the nano switch)
  3. Seemingly not, although I am not sure what the time frame is on the stats I see in JS UI. I will look into this. I did try and add the nano switch in secure mode to try and reduce traffic, but despite it claiming in the documentation that it supported secure mode, I could not include it that way.

Based on your description The nano switch is up in a metal fan enclosure next to fan. Could be a tough RF environment. If you are using zwavejsui there is a test button that can be used to test it. There are also a set of diagnostic counters in HA form the device. Enable those, add to recorder and make a dashboard. The diags like tx,rx, etc. reset whenever zwavejs is restarted.

The nano switch is in a metal enclosure. However it is not next to the fan; the switch is above the internal door and the fan is on the opposite side of the bathroom on the external wall. I did try leaving the antenna outside the plastic switch housing to see if that would help but it didn’t seem to have any noticeable effect. I’ll follow up your recommendations in zwavejsui and see what I can gather. Although after adding it again yesterday with a full factory reset of the device itself it’s unavailable as usual today…

I don’t seem to be able to find a “test” button anywhere in zwavejsui, nor anything else that suggests it would test the mesh. However it’s clear from the network diagram that no mesh exists and each device is connected directly to the controller.


I’ve enabled the diagnostics on the device, but of course I will have to remove it and add it again to add those.

I’ve had debug logs on, and after adding it successfully at 13:58:41 with no error messages in the logs, it simply died at 20:45:07 with a very uncerimonious;

2024-05-01 20:44:54.365 INFO APP: e[0mGET /health/zwave e[36m301e[0m 1.191 ms - 191e[0m
2024-05-01 20:45:07.557 INFO Z-WAVE: [Node 012] Is now dead
2024-05-01 20:45:24.466 INFO APP: e[0mGET /health/zwave e[36m301e[0m 1.250 ms - 191e[0m

There’s nothing that looks out of the ordinary in there to my untrained eye, the health first ms never go into double digits. The diagnostics also don’t seem to show anything out of the ordinary, other than it being dead without any apparent reason.

click a node and context menu/popup appears

diganose will do a roundtrip measurement

Ah yes. I’ve seen this. I have just re-added it. As usual, it would not include securely, even though I tried the force option. Node looks to be in prime health.

The node has only 1 neighbor and at somepoint that route fails and there is no fallback, and so the it goes dead.

There may be something intermittent causing issues. Microwaves, laptops WiFi all seem to cause changes in RTT in my system. Also, power line noise seems to affect Aeotec smart plugs caused by compressors, motors, pumps.

I’d try adding in a couple of smart plugs to get a mesh.

I’ve forced a priority route to the smart plug I bought to see if that had any effect. I’ve placed it physically closer to the fan as well. This does seem to have had a positive effect for now, and made it possible to resurrect the dead node. But right now if I have to invest any more money into this it will be to test Zigbee solutions rather than Z-Wave, as I have a much better mesh with that. Thanks for all your suggestions.

Jumping in here to say I’m in a very similar situation to @reclusivemonkey
However, it is one of my Yale Connexis locks which keeps becoming unavailable. I have an Aeotec smart plug right next to the door, purely to act as a repeater, but despite that being alive, the door lock is currently unavailable.
Perhaps I will try upgrading to Z-Wave JS UI, and try some of the suggestions here.

With regard to the Nano switch, I have some of those too, and they work ok for me, but I have had the odd Zigbee switch become unreliable over time. They are pretty cheap, and so when it got too annoying, I just replaced them. Maybe if the Nano is still causing issues, you could try replacing it, and you can always keep it as a spare or use it for something elsewhere in the house.

Thanks Nick. The possibility that the nano switch is at fault here did occur to me, but for now it’s been relatively stable since I set up the plug forced to be a repeater.

I really feel your pain with the Conexis. It’s a real deal breaker for us Smart Home enthusiasts if we can’t actually get into our smart home. I actually ordered the replacement module from Yale for the new app, but I want to keep that for when I eventually move to give to the new owner, which will hopefully be a smooth handover fot the “lock”. I always use the best Duracells I can buy and my lock is within a couple of meters of my front door. I think another reason my lock is more stable is that it is of course added in secure mode, which as I understand it is less busy in it’s communications.

Good luck!