Aeotec Provided 7.20.2 Firmware for USB 700 Stick

Here’s the link to the updated article.

I have an email from Aeotec support with 7.21.0 as well. I’m debating whether to update to 7.20.2 or stick with what I have (7.18.1). Anyone else rolling with a 7.20 or later firmware that can give us some insights?

I’m on 7.19.3, haven’t noticed anything different. Things work as expected, the infamous dead node issue still present. I’m planning to update to 7.20.2 tonight. Wouldn’t mind trying 7.21.0. Could you share that e-mail and the 7.21.0 file ?

Here’s a link to 7.21.0.

Use at your own risk, I have not tested it yet.

Pertinent excerpt of email:

You can use ZWaveJS UI or PC Controller 5 to change the Z-Wave Frequency whenever you want. (The US Z-Stick 7 is optimized for US Frequency so you’ll see lower ranges in other z-wave frequencies).

I have the firmware for 7.21.0 here already i’ve attached it if you’d like to try it out as well.

Cheers,

name redacted

Field Application Engineer

Aeotec Inc.

Data provided is processed inline with Aeotec Group’s privacy policy and terms of use

1 Like

Updated to 7.20.2 this morning. A test from Shelly Wave 800 (QNSW-001X16) at 5 meters from the Aeotec Z-Pi 7 controller gives terrible results (see below). Previously on firmware 7.18 and regularly facing dead nodes.

I am a frustrated ZWave consumer spending too much time on this. IMO SiLab chips are the worst that happened to ZWave. I should have stayed on 500-series and never listened to all the 700-series BS.

3 Likes

nordic70, sorry you’re having such issues. Out of curiosity, are you using a passive USB 2.0 extension cable for your Aeotec? I’ve been on 7.18.1 for some time now, and had horrible issues initially, but once I put in the extension cable things got way better. I haven’t been seeing dead nodes in some time.

Are those European devices/frequencies? Do you have the correct frequency set for the USB device post firmware upgrade? I think it defaults to US after the upgrade?

Update on this, updated to 7.20.2 right after all the main HASS February updates came out. Things have been stable for a couple weeks now. Performance seems fine.

Still waiting on an update on test results from Aeotec before updating to 7.21.0. Maybe by that point it will be at a .1 or .2 version.

I’m on 7.21.0 and it’s terrible. Dead nodes issue , controller jammed issue and the network is now slow AF.

I have a simple automation with a zwave switch that is turning on 4 rgbw z-wave dimmer modules that used to work perfectly fine before and now it’s totally broken. Sometimes, 3 out of 4 module turns on almost instantly, the 4th one takes up to 1.5 minute to turn on or the node dies and the controller is reported as being jammed.

Im loosing fate in z-wave on home assistant. Seems like no ones care about z-wave anymore, even not SiLabs.

What HW are you on, how much RAM? I ask because there is evidence that newer version of HA and zwave are using more memory and are causing slow downs on limited memory systems. If you have less than 4GB of RAM that could be the issue.

im using an intel N5095 mini pc with 16gb ram, pretty sure this isn’t the problem but thanks for the info!

Finally an answer from SiLabs. :+1:

3 Likes

Any update on this? I’m running a Z-Wave mesh with 66 nodes (~40 powered, 26 on batteries).
I have been logging the performance of the mesh for the last month (downloaded and analysed the daily logs).
I have on average 7-8 controller jams per day (with lights not going on/off, etc.).
And I do have the Z-wave 7 stick on a 0.5 m USB cable, far away from my HA-NUC, so not much I can improve on that aspect.

Really looking forward to have the jamming issue resolved

I feel you. They unfortunately failed to deliver, and its users are getting very frustrated in their own community board:

1 Like

7.21.1 they finally acknowledged the issue after months being reported:

in 7.21.2 they did not solved the issue even if they told us they were going to, saying they were working on this as a top priority:
image

in the 7.21.3 release notes, they are now saying the issue is a “low occurence issue”. :neutral_face: Is it a polite way to say that they dont give a F anymore or are they trying to win some time ?..

I’m now looking to downgrade to a 500 series stick since this looks to be the only solution if you don’t want to wait for SiLabs to fix their firmware. I dont have hope anymore, the 700 series is there since 2019 and yet it never worked correctly (dead nodes issue and now this controller jammed issued). I miss the days I was using my old VeraLite controller (Z-Wave 300) but unfortunately upgraded to the Aeotec gen 700 stick to be able to use somes Inovelli switches with Home Assistant and Zwave JS.

Does anyone asked Aeotec for the 7.21.3 firmware file? If yes can you share it here please?

1 Like

With the upcoming Home Assistant z-wave stick as per the state of the open home, I am worried about how it will play out. As z-wave chips are only produced by Silicon Labs and one other manufacturer and with Nabu having a partnership with Silicon Labs, I assume they will be providing the silicon. This is starting to become a farse of bad communication, broken promisses and negligence towards one of their most active user bases and corresponding communities.

Again, for those not up to speed, have a quick look at one of SL’s own threads: Silicon Labs Community as well as one of the many zwave-js issues concerning the same root cause: Controller reporting "Jammed" and then "Ready", operations hang · zwave-js/node-zwave-js · Discussion #6512 · GitHub.

I would love a take from someone at Nabu on this regarding current and upcoming firmware/hardware blocking issues where the open source community can’t help out themselves. Both because of the upcoming stick from Nabu’s side, but also because of their possition as partners with access to priority lines and other means of communication channels besides the one we try to use, but SL rarely show up in. @frenck, @balloob, Uwe or Dominic perhaps?

From an Aeotec Help Desk employee:

I uploaded it to github if you want to try it.

I flashed it on mine 2 hours ago:

I saved two month of log files from zwavejs-ui and analyzed those with a number of scripts. (I have 66 devices, 40 direct powered and 26 on batteries, number of motion sensors that generate quite some messages)

I noticed two different problems with the Aeotec gen-7 stick (7.20.2 firmware):

Jamming: on average 4-5 times a day, stick jams for about 4-5 seconds, thereafter working fine (until the next short jam)

Locking up: during the two months logging, stick locked up twice, only remedy is a soft reset of the stick.

I noticed from the SLab website and the note above from the SLab engineer that the jamming issue might be solved in 7.21.2, but that the occasional lock-up still is on the list of known problems (even in 7.21.3, see release notes on SLab site).

If I have some time in the coming days, I will update firmware to 7.21.2) and see if jamming issue is indeed fixed.

SiLabs should definitely just open source the firmware at this point. It’s beyond ridiculous…5 years of issues on the 700 series!! Obviously they’re not willing to throw enough dev resources at the issue, so leverage the community. More eyes on it, the better.

Hopefully with the push from the HASS foundation members, things will change.

@wimjanse would appreciate you dropping any results here if you upgrade.

@Alain_Raymond thanks for the 21.2 firmware.

So I updated the Gen-7 stick with 21.2 firmware 3 days ago (from 20.2)

Two days is not much of statistical data, but I already see that the jamming issue is NOT solved, I had 3 jams yesterday and 2 already today.

If someone from Aeotec and/or SiliconLab is following this forum discussion: Could you put some more effort in solving this jamming and locking issue. If this helps you, I have now two months of full ZwaveJS-UI logs that I can make available for analysis (based on 66 ZWave devices, mix of battery and direct powered).

For now, I keep on logging for a few days, then go on holiday, but thereafter I plan to change the Gen-7 for a Gen-5 stick and see whether I get a better performance. I started with HA ZWave 3 months ago (coming from a Fibaro HC2 system), and I’m quite disappointed with the Aeotec Gen-7.

Question: I have no experience with Z-wave 700 based sticks from other vendors, do those have similar issues (I image so, but am not sure). Any update on this would be appreciated
.