Aeotec Smart Switch 6 - intermittent behaviour

I really hope someone can give me some advice here, as I seem to be going around in ever decreasing circles.

I have a number of Z Wave devices on my system, including motion, door, flood and smoke sensors. I also have a TKB smart plug. All of them are automated via their own .yaml file and all of them work as expected. Considering my complete lack of experience with Home Assistant, I was feeling pretty good about it.

Enter the Aeotec Smart Switch 6…

For the life of me, the damn thing seems to have attained self-awareness and it’s mission appears to be to cause torment.

Modifying the code that I have used (successfully) for all the other sensors, I have attempted to detect when it is turned on and off and to record the wattage being used. All of this information is sent to a database using the “service” call and parameter:

#Aeotec Smart Switch ON
- id: '1202'
  alias: 999-AP-AP1SON
  description: Aeotec Smart Switch has been turned on
  - device_id: 999-AP-AP1S-ON
    domain: switch  
    entity_id: switch.aeon_labs_zw096_smart_switch_6_switch
      hours: 0
      minutes: 0
      seconds: 1
    platform: device
    type: turned_on
  condition: []
  - data:
      url_param: ?R=V&A=0&M=999-AP-AP1S&D=255
    service: rest_command.ccc_send_static
#Aeotec Smart Switch OFF
- id: '1203'
  alias: 999-AP-AP1SOFF
  description: AeotecSmart Switch has been turned off
  - device_id: 999-AP-AP1S-OFF
    domain: switch  
    entity_id: switch.aeon_labs_zw096_smart_switch_6_switch
      hours: 0
      minutes: 0
      seconds: 1
    platform: device
    type: turned_off
  condition: []
  - data:
      url_param: ?R=V&A=0&M=999-AP-AP1S&D=0
    service: rest_command.ccc_send_static
#Aeotec Smart Switch WATTS (NOT WORKING)
- id: '1204'
  alias: 999-AP-AP1W
  description: Wattage change on Aeotec Smart Switch
  - entity_id: sensor.aeon_labs_zw096_smart_switch_6_power
    platform: state
  condition: []
  - data_template:
      url_param: ?R=V&A=0&M=999-AP-AP1W&D=
      url_value: '{{ states("sensor.aeon_labs_zw096_smart_switch_6_power")
    service: rest_command.ccc_send_value

Sometimes it sends readings, sometimes not. The on/off part is slightly more reliable, but the wattage readings are rarely sent. It usually works if I have rebooted, but then stops - and I have no idea why. I’ve changed it around and even done a fair amount of blind experimentation.

I’ve paired it “normally”, I’ve paired it in secure mode. I have also attempted to pair it using the Aeotec Stick I using for Z Wave (and that was a complete disaster).

Is there something really obvious I am missing? Any advice or help would be greatly appreciated because otherwise I will thwart the rise of the machines by throwing it out the window!

Have you changed any of the configuration settings? It doesn’t look like any power measurements are sent by default.

1 Like

What is the value of parameter 80? Basic, Nothing, or Hail? Nothing means the switch will not publish any updates and the values must be polled manually. Basic means the switch will notify the primary node/controller it has an update to a value and the controller must poll the node for the update. Hail is the device flooding the network with data every time something updates and should be avoided to prevent crippling the Zwave network with too much traffic. Also parameters 101, 102, and 103 set the reporting groups (what gets reported such as voltage, wattage, amperage, energy usage) and 111, 112, and 113 are the corresponding update intervals. These are the 7 basic parameters that must be configured for semi-reliable operation of the switch and meters it provides. Also the ZW096 Smart Switch 6 must be included as secure devices and there must be a network key set for the Zwave network.

1 Like

Thanks for the replies.

Parameter 80 is set to Basic (I’d read about that in another topic).

I’ll take a look at the other parameters you’ve suggested - do you have any recommended settings?

I have tried pairing the device securely, but haven’t set a network key - so I’ll look at doing that too.

Many thanks for the help - having something to try at least gives me hope that I might be able to get it working!

The reporting groups can be a little difficult to understand. Here’s a good breakdown of the parameters.

Mine is configured as follows:
Parameter 101: 1
Parameter 102: 6
Parameter 103: 8
Parameter 111: 180
Parameter 112: 90
Parameter 113: 86400

What this translates into is: I get a Voltage update every 180 seconds, a Current and Wattage update every 90 seconds, and the total Energy usage in kWh once per day. The report type parameters are cumulative, so whatever you want in that parameter report, add up those values (Current (2) plus Watt (4) is a value of 6). I found this to be a decent balance between value updates and communication traffic.

There’s been a long standing recommendation for ZWave to never poll a node quicker than the network can handle. Typically this is no quicker than 30000ms (30 seconds). On larger networks it’s going to be longer, but smaller you can get away with quicker. Setting your reporting interval parameters to no quicker than 30 seconds is no different.


Thanks squirtbrnr, that’s really helpful.

I’ll hopefully get some time on it in the next day or so and will report back.

I’ve had a play around this today and I think I have it working.

Many thanks squirtbrnr, I really appreciate it!

As a new Z-wave user, it took me several reads to understand this, but I got there.
Thanks so much!

If you have time, I’d be interested in the rest of your parameter settings with a little explanation as to what it means and why you’ve chosen it.

…in my HA front end I get a light from the Smart Switch 6, but can’t seem to make the LED change colour.

Many thanks!

The problem is the way I described the parameters is based on the old built-in ZWave integration (which is now deprecated and removed). While the parameters and their values have not changed because they are specific to the device, the way they are set is different in the new ZWave JS UI. It’s still a cumulative number, but it’s broken out into enable/disabled each measurement value per reporting group.

All of the parameters not described above in my posts are set to defaults. I haven’t changed any others.

I never tried to get the light working. The only thing I could do was change the mode via a parameter so it was on, off after 5 seconds, or “nightlight mode”. Maybe the nightlight mode enables the ability to change the color or brightness? I don’t know because I’ve never tried.

Ok, even that is useful to know!
I was trying to work out why I didn’t have the cumulative numbers but thought it was UI thing. But when using the URL link you mentioned it made sense.

Yeah ok I might give it a go, just for fun.

Do you still use your smart switch 6, or have you changed your hardware?

Thanks again.

I do still use them. Mostly for the energy reporting, not so much the switch or night light functionality.