Aeotec Stick Gen 5 pass through VirtualBox on macOS

Tags: #<Tag:0x00007fc418f08d98>

Long-time home automator considering moving to HA from Indigo. Got HA up and running using OS install on VirtualBox on a Mac (running Big Sur). All very smooth and having a play around. Critical component for me is to get Z-Wave working since I have 50+ Z-Wave devices in my setup. I am using an Aeotec Get 5 USB stick and trying to get that working with the Zwave JS integration. I cannot get that working and since I’m a novice on Linux, HA and VirtualBox I’m not even sure where the issue might be. I’ve read and tried every suggestion in every previous post I can find on the topic with no joy.

In VirtualBox on the config for the VM, Settings > Ports > USB I have enable USB controller enabled and a filter added for the USB stick (“Sigma Designs Inc”).

When I go to the Zwave JS integration in HA, Config tab the drop-down for path, drop-down options include /dev/ttyS0 through /dev/ttyS3. Whichever of these I choose I get the exact same result in the Log section for the Zwave JS integration, namely:

2021-04-05T08:37:30.049Z DRIVER version 7.0.1
2021-04-05T08:37:30.050Z DRIVER
2021-04-05T08:37:30.095Z DRIVER serial port errored: Error: I/O error setting custom baud rate of 115200
Unable to start driver [Error: Error: I/O error setting custom baud rate of 115200]
[09:37:30] INFO: Successfully send discovery information to Home Assistant.

I’ve no idea whether the issue is with HA, VirtualBox or my Mac. I’d be eternally grateful for any pointers in the right direction. Thanks in advance!

For anyone else hitting the same problem, I eventually managed to solve it myself as it turned out the default VirtualBox install only supports USB 1.1 which didn’t work. I installed the VirtualBox extension pack matching my VirtualBox version number and then I could select USB2 on the settings for my virtual machine instead and that solved it. Various articles suggested I would also need to add my current user to the vboxusers group before this would work but I found there was no need.