Aeotec USB Z-Wave Plus initial installation

Good evening, I really hope someone can help me to fix my problem.
I ordered a Z-Wave Controller to command my Z-Wave switch’s over Hassio.
But now I have the problem that, if I install the Z-Wave Addon on Hassio, the initial Installation run and run and run. There will never be seen my Z-Wave Controller. I mean it run over 4 hours without a result. See also the picture.
I have there only the possibility to start the search. If I look on YouTube the tutorials the people had there more selection options.

I also changed the USB Slots. That will mean that I try it with - /dev/ttyAMA0 and /dev/ttyACM0 – but with both I had the same result. It searches but it will don’t find my Z-Wave Controller.

The second question is.
If I install the Z-Wave Addon over the configuration. See attached picture
What options, I will get over the Addon “OpenZwave”? Can I install both or only one of them?

Thanks for your help and a nice evening.


What did you install HassIO on, and which Z-wave controller did you choose? There are reports of problems with the Aeotec adapter installed into a Pi4 that are fixed by using a USB2 hub in-between the Pi4 and the zwave controller.

God morning

First, thanks for the fast answer and the Information about this issue.

It is exactly as you write. I use a RASPBERRY PI 4 4G with an Aeotec - Controller USB Z-Wave Plus Z-Stick ZW090C GEN5. But I do not understand why an USB hub should fix this issue. I have on the PI two USB 3 ports and two USB 2 port. On all ports I get the same results. But how I can choose the right port by the installation of the z-wave application?

This morning I teste with an USB-extension cable - Same result. I have here at work an old USB 1 hub. Do you know if it also works with this?

Thanks for your fast support.

Best Regards

It is a HW problem between the Pi4 and the Aeotec device. The work around is to use an external USB 2.0 hub. You can try your existing USB hub, I don’t know if it will work or not. I am still running on a Pi3b.

Thanks for your fast answer and the link.
Perhaps I must read all the in a quiet minute.
In moment I cannot understand, why it does not work on the USB 2 ports without this hub.
But I will test if it run with my USB 1 hub. If not, it looks like I need to buy one with USB 2 compatibility.
But I understand right. The USB hub does not need an external power supply?

I tried with an unpowered USB 2 hub and it would not work for long before it disconnected. I temporarily used a powered USB 1 hub and it’s been rock solid. Someone on this forum pointed out that a powered hub is needed.

I’ve got the same problem. I tested with two different non powered USB 2 hub, it doesn’t work.

Hey, thanks for your statement. Sounds not good. So, the chance, that the Z-Wave stick works with the ordered USB 2 Hub next Tuesday is very small.
Do you - ore someone else - know, if the problem exists with another Z-Wave stick too. Is it possible to fix it with a Z-Wave stick like UZB1 stick?
Hope, I can command my Z-Wave switches over hassio soon.

I have 2 sticks. The Aeotec Gen5 and the Nortek z-stick (tried both on a RPi4). With the Gen5 stick, I had to use a powered usb hub. The the Nortek stick, I had interference with the z-wave, which shortened by comm distance. All in all, I used a hub to get better separation, which eliminated the interference. The hub is optionally powered, and I connected the power because it seems like a good idea to have.

OK, that sounds like I can send back my no powered USB 2 Hub and order a powered one.
Hope this will be the solution, to run Z-Wave on hassio.

I tried with an old powered USB 2 hub, and it works without the power supply connected. But I finally decided to use a Raspberry 3 B + instead of a 4.