Aeotec Zwave Stick Problems

Hi, I wonder if anyone can help me please?

I have recently purchased an Aeotec Gen 5 Zwave USB stick for my HA install which runs on a PI 4.

The initial install following Aeotecs instructions seemed to work ok, but I have noticed over the past few days , I am now seeing this error with the Zwave integration

Retrying setup: Cannot connect to host a0d7b954-zwavejs2mqtt:3000 ssl:default [Connect call failed (‘’, 3000)]

I have tried to reset the box, unplug and plug back in the Aeotec stick and check through the config… but still the same. Also tried to reconfigure via the zwave js to mqtt UI but this error is always displayed

Driver: Failed to initialize the driver: Timeout while waiting for an ACK from the controller

When I go to settings and then click save I get a secondary message

Driver: Error Resource temporarily unavailable Cannot lock port

Can Anyone suggest how I might fix this as I don’t want to start adding z wave devices if this is not reliable .

In case its relevant the Aeotec instructions get you to install z wave - js first and then update to zwave js to mqtt. Its the z wave - js integration that is showing this error

Many thanks


Just a quick update … I ran the update to Zwave js to mqtt and then tried to run a heal network, soft reset and then last resort a factory reset and all action had the say error

Error while calling api hardReset: Zwave client not connected

If I take the Aeotec Zwave stick and plug into a windows laptop and run the aeotec tool it sees it and reports it correctly … so I dont think its hardware .


Hi … thanks for the reply but I’m sorry I don’t have a clue what you mean … sticky what?

So back to the question in hand … anyone know how to fix my broken z wave config … or do I need to return my zwave stick as faulty ?

The grey box in francisp’s post is a link, click the title and you will see the instructions on how to fix the issue.

Hi Apologies

There wasn’t a grey box in the post and I didn’t realise there was more in his post below.

I actually found the same post by searching … so just about to look and see if this will work for me.

Thanks for the help



Well thank you for the assistance and feedback but this did not fix the problem … so I’m confining the Aeotec Zwave stick to the trash as I cant have something that unreliable and difficult to configure. T

Very disappointed that what I thought was a good make in Aeotec turn out to be total rubbish

This also makes me consider the use of HA as a replacement for Smart things . Id started a while ago and only recently taken the step to buy the zwave hardware with the intention of moving devices over from ST , glad I didnt as this as been a bad experience and a waste of money …I wasn’t keen on add on usb sticks/modules in the first place so going to park the idea and re-evaluate the use of HA

Shame the new HA boxes aren’t all inclusive with zwave and zigbee like ST.

I can understand the frustration, especially when learning anything new, but what else have you tried? Throwing it in the trash seems a bit premature. I have an Aeotec Zstick 5 and it works fine with my Home Assistant install. It seems there are some configuration problems with the Aeotec Zstick and a Raspberry Pi 4 (I don’t use mine with an RPI), which if so is a hardware conflict/issue outside of Home Assistant. See this link to the issue mentioned on the Raspberry Pi Forum, which describes the issue similar to what was posted above by francisp. There are some potential solutions mentioned there, like using an inexpensive USB hub between the RPI and the Zstick.

The new Home-assistant amber (More info here) Home Assistant Yellow includes zigbee. From what I heard, adding another radio like zwave would have required additional FCC licensing in the US, and likely other countries, not to mention zwave in Europe is an entirely different frequency then the US, vastly delaying the project. Zwave also is not on board with matter, and the future of it is way more up on the air. Plus, there is the additional cost to add this, when many people don’t use Zwave. It makes sense to me they wouldn’t include it, but give you the option to plug in a zstick.

If you want an all inclusive box that might be more user friendly ( that is when their cloud is actually working) , SmartThings might be the better option for you. If anything, you’ll want to at least save that Aeotec Zstick from the trash, because you will need it to install firmware updates on Zwave devices, as Smartthings can’t do this.

My gen 5 z-stick has run on HA flawlessly for 4 years. They are actually really good. I initially had it connected to a RPI3B, then a Celeron NUC, now an i7 NUC. It has worked great on all devices.

Sort out your particular issue rather than scrapping a perfect device (unless it is in fact faulty, but chances are slim).

The Aeotec sticks are pretty much the reference in terms of quality and zwave support. They’re widely used here, probably the most used zwave USB stick on HA. My own gen 5 stick has been working without any flaws since I started with zwave. If I ever upgrade to gen 7, I’ll definitely get the Aeotec one.

From the very vague descriptions you mentioned, this doesn’t look to be a problem with the stick at all. But with your serial port being unavailable / already used or a permission issue. You don’t happen to run the two zwavejs addons at the same time, do you…

You need the PLUS version for the RPi4. See this from the Aeotec website:

“New Pi from Raspberry, new Z-Stick from Aeotec. As it was built upon an older Z-Wave stack, the non-plus model of Z-Stick Gen5 isn’t compatible with Raspberry 4. But Z-Stick Gen5+ is.”

Thanks for all the feedback… After a frustrating few hours of not getting it to work, i left it for the day whilst at work and revisited again tonight. I found the 1.5K resistor I soldered in wasn’t quite connected at one end … so a very fiddly hour later it is and it installed first time. However it did before I modified it so only time will now tell… but looking promising. Will post back over the next few days with an update.

Thanks again everyone




So Aeotec’s solution for providing a device that doesn’t use the proper voltages, and violates the USB specifications, is to buy their new device? You’d think they would at least offer a coupon code or something.

Technically they shipped a defective product and should replace it for free or at least offer a heavy discount. But yeah, well, you know how these things go.

If you’re in for a new stick at this point, regardless of the reasons, you should probably go for a gen7 anyway, rather than the fixed new gen5.

1 Like

So it’s been about a week since I started the fix with my Aeotec zwave gen 5 stick and I’m happy to report the hardware fix linking R33 to vcc appears to be a good one as it’s still working.

I haven’t added any zwave based devices yet but apart from a red symbol on security in the zwave settings I’d say I’m safe to resume my migration from Smarthings …

I do agree that Aeotec should offer some form of discounted upgrade but that is unlikely to happen , so I’m grateful to all who spent the time working out the fix.

Thanks for all the help

Regards Andy

It appears a new firmware was released for the older gen5 zstick to make it equivalent to the firmware on the gen5+. I wonder if updating the firmware would fix this rpi4 issue without needing to purchase a new device

Highly unlikely. The problem with the old stick is an electrical issue on the USB side, with a wrong pull-up voltage on one of the USB data lines. That’s not something you can fix in software. You can fix it with a small hardware modification of the stick though.

Yeah doesn’t sound like it would fix a hardware issue like that. I just applied it to mine, it at least got rid of the annoying 3 color disco light show. Too soon to tell if it will improve anything else, but at least it went smoothly and didn’t mess up the network. I did a backup first but didn’t need to use it.

Hi, not sure if this firmware is correct. Let me explain…

Mine (gen 5) showed ver 1.1 but as Tim said displays the disco lights with zwave + and security in red.

So I wasnt sure that any upgrade to 1.02 was actually a forward step as technically at 1.1 mine shoudl be at a later version, but I’m not aware of Aeotec’s versioning sequences so I thought as a later release … why not try after all if the udating tools as been written correctly it would highlight this.

Nope it didnt … it ran through the update completely and indiated it was successful. However after putting back into the PI4 and a restart of HA and it still reports 1.1 with the same disco lights.

So my assumptions are that it did realise the version installed was greater and didnt upgrade it, but the upgrade software is poor and did not warn or error.

Either that or Zwave JS to MQTT is not reporting the true state. I think given the poor build by Aeotec not following USB standards, my monies on theor upgrade s/w being poor. Any thoughts ?

Mine shows 1.2 in zwavejs2mqtt now after the update. The light is generally solid green now unless the battery is charging, which from reading release notes is what the new firmware should do.

So it appears the 0 in between 1.02 is omitted, or something is wrong either with how zwavejs interpretes the version, or how the zstick reports it.

It sounds like your firmware failed to update and I’m unaware of an “in between” version between the original and recent release. I would try and do it again, there are a bunch of steps and drivers needed and I imagine it can fail at several points along the way. Agree upgrade software should confirm if successful or not , not sure why it doesn’t