After "dpkg -i homeassistant-supervised.deb" DNS are lost

I’m trying to install Home Assistant Supervised on an Intel Atom 330 machine.
I’ve followed the installation guide and I managed to install debian 11 correctly. Network works (it downloads all the updates and the needed files without problem).
But after I give the last command:

dpkg -i homeassistant-supervised.deb

even after one hour I can’t get access to the User Interface…

So I tried the command:

sudo journalctl CONTAINER_NAME=hassio_supervisor

and I can find this error being repeated forever:

feb 16 16:55:11 homeassistant hassio_supervisor[19633]: 23-02-16 16:55:11 ERROR (SyncWorker_0) [supervisor.docker.interface] Can't install 500 Server Error for http+docker://localhost/v1>
feb 16 16:55:11 homeassistant hassio_supervisor[19633]: 23-02-16 16:55:11 WARNING (MainThread) [supervisor.plugins.cli] Error on install cli plugin. Retry in 30sec

I tried pinging or any other host but it does not work.

I also tried this:

root@homeassistant:~# nmcli c
NAME               UUID                                  TYPE      DEVICE 
Supervisor enp5s0  1c36050c-dfea-4115-b881-f678b8db12c7  ethernet  enp5s0 

root@homeassistant:~# nmcli c show "Supervisor enp5s0" | grep -i -e name_servers -e dns
connection.mdns:                        2 (yes)
ipv4.dns:                               --
ipv4.dns-search:                        --
ipv4.dns-options:                       --
ipv4.dns-priority:                      100
ipv4.ignore-auto-dns:                   no
ipv6.dns:                               --
ipv6.dns-search:                        --
ipv6.dns-options:                       --
ipv6.dns-priority:                      100
ipv6.ignore-auto-dns:                   no

It looks like there are no nameservers set…
How can I solve?? As I said, the network worked perfectly until I installed homeassistant-supervised-deb

Thank you

Ok, I followed these instructions to set DNS manually:

And now it works.
Still I’m wondering how come DNS were lost abruptly after the dpkg command.

They were probably lost when setting up the NetworkManager.
They may just first have effect when Supervisor was started up because it might have refreshed the network settings.

Still this does not look like normal behavior, and I guess it shouldn’t happen. I wonder why it did.

NetworkManager nearly always mess up the network settings. It is more a fact than a chance.