After installing HA on a Raspberry PI, is no long accessible

I installed HA on a Raspberry PI. After installation is no longer accessible on any computer or google device. I removed HA from the network and Google still not accessible. Contacted FIOS and the changed my IP address. Still not accessible. FIOS recommended contacting HA. Without Google, all of my Google devices including WiFi are no longer usable. I have attempted every fix I could find on the web. No change. It is so frustrating that my existing SmartThings network is no longer usable. I was leaving SmartThings due to problems and heard HA was the best. After 14 hours of troubleshooting I am frustrated. Any help to get my Google connection back would be greatly appreciated. Thank you in advance! My apologies, this is my first post. I hope I made my issue clear which is is not accessible on any device on my network.

This is a classic non-sequitur. One has absolutely nothing to do with the other.

Verizon knows nothing about Home Assistant. Nothing. Changing your public IP address should have no effect on any of your devices which tells me that the FIOS support person was just spitballing from ignorance.

How is your WiFi dependent on This makes no sense at all.

How did you post your question here?

Describe your system. Is it Verizon FIOS? Are you using their ONT (Optical Network Terminal) and router? Do you have a PC with an Ethernet connection to the router?

Stevemann is correct.
HA should not directly affect your access to
It can only affect your other devices if you have made changes on your router, like trying to set up a DNS service on the HA and then made changes on the router to send DNS traffic to HA.
If that is the case, then you need to either reverse the changes on the router to let the DNS traffic go to the ISP provided servers or you need to fix what might be wrong on the HA DNS service.

The FIOS support should have catched the changed DNS servers settings and reverted those to the ISP provided ones. It is one of the first step you do in troubleshooting.

Did you add adguard home or pihole?

Thank you so much for your replies! I have not added adguard home or pihole. I agree that the FIOS response was not accurate. My plan is to contact FIOS again today to see if another tech is able to resolve. I will be the fist to admit that my network abilities is limited and will need to seek help with reversing the DNS server settings.Hopefully the new FIOS tech can assist.

My system is internet service from FIOS to their router. I have a Nest router connected to the FIOS router via an Ethernet cable. Describe your system. Is it Verizon FIOS? I believe I am using their router (coax to router from exterior of house), not an ONT (Optical Network Terminal) and router? I did connect a PC directly to the router with an Ethernet Cable. Same results as using WiFi. None allow access to the that website. Thus far that seems to be the only website.

Again, that you all for your time and suggestions! I am eager to set up HA if I can get past this roadblock! Have a wonderful day!

That might be the issue.
Make sure that you use different subnets on WAN and LAN side of the Nest router!

UPDATE: I just spent an hour on the phone with Verizon. The verified that my router is not the problem by having me connect before the router connection. Then they had me do a tracert at the command prompt. It went through 3 routes and timed out on the 4th and 5th, went through on 6 and timed out on 7 through 13. They said based on timing out on 4 it is a Verizon issue. They now have to go into their databases to see what the cause is. A ticket was generated. They say they will reach out to me today with either indicating it was resolved or what they are doing. The saga continues. I will keep you updated.

UPDATE: Nothing from Verizon. Ticket still open. Scheduled completion is 45 minutes away. Problem still exists. If I go to another location with my computer, all works fine so it is not my computer. Waiting to see if Verizon figures this out!