After mystery crash, HA no longer boots up

What had happened was…

I noticed lights suddenly not working and checked on server PC to find my HA not running and VMware closed. I can no longer start my instance of HA. I’ve researched a few different possible causes, but no scenario seems to match mine and no luck resolving so far. Hoping folks might be able to point me in the right direction. Details below…


During boot, I notice that one item fails and the boot sequence stops ("FAILED Failed to start docker application Container Engine See ‘systemctl status docker.service’ for details.

Once the sequence stops, it automatically attempts to boot into Rescue Mode where I assume I would be able to see the log, however I get another error, “sulogin: tcgetattr failed: Input/output error” and I’m not able to boot Resuce Mode.

Installation information

I have HA installed on a WMware Workstation Player (17) on Windows 10 host. This PC is usually 24/7 and runs other servers and BlueIris.

What I’ve tried

  1. Create new VMware virtual machine and move HA disk over but same result.
  2. Create new VMware virtual machine and upload last backup .tar - result: Able to install SAMBA and manually copy large backup file to the /backup folder but the file never appears in the UI. Holding on this troubleshooting to explore solutions to remediate original installation (backup file not as recent as I’d like).
  3. Expand VM disc size from 32 to 42 GB (read that disk space may be issue): result - after adding size to WMware settings, popup informed I would need to make additional changes “within”. Not sure what that means but now I can’t even boot the VM to see the errors.

Next steps?

I’m not sure if I’ve done irreversible damage to the VM settings by clicking the Expand Disk button, if it is still possible to troubleshoot shoot the existing VM, or if I need to move on to troubleshooting my backup into the the new VM and HA installation.

Appreciate anyone’s guidance in advance!

Update: I was able to successfully restore an even older backup to the new VM. I assume the latest backup I had was corrupt in some way. Not ideal but I’m happy to avoid rebuilding from scratch and can quickly catch up changes over the past few months.

I’m going to proceed with the restored build but will continue to troubleshoot (if possible) to understand what happened or how to resolve in the future.