After Update to iOS 16.4 media_player.play_media not working anymore in automations

I have several automations, which play media sounds on my homepods. It worked all perfectly until the update to iOS 16.4. Now nothing is playing and i get the error-message:
no responce to ANNOUNCE rtsp://<IP-Adress of HA>/123456 (RTSP 1.0)

In the log is the following warning:

Logger: homeassistant.components.apple_tv
Source: components/apple_tv/
Connection lost to Apple TV ...

Has anyone else this problem?


Same problem here. Since 2 days no more responses from tts.

Yep, same here since iOS update to 16.4 on my HomePod mini.
Before that, it happened from time to time and I just had to restart the HomePod. but now it’s permanent and no restart fixes it.

I guess, something was already a bit flaky since a while but only generated errors sporadicly.
And now Apple changed something and it has become completely out of the Apple TV integration specs.
Good news is because it is permanent now, it will be easier to debug.

1 Like

I had the same problem, probably like @iDevice with iOS 16.4. After three or four days of my good morning message no playing, it worked this morning. I have auto-update turn on for my HomePod so maybe there was a fix from Apple or it just corrected itself. HomePods are a continual source of problems when there are updates.

I don’t think there was an update from Apple, well at least I didn’t get any.
That said, tts does succeed from time to time and I guess that’s what you got this morning.
I have about 20 automations sending voice messages and I get only one per day going through, if lucky…

I have the same issue for two HomePods. Sometimes it works, but most of the times it errors with the exact same issue…

Having the same issue here - watching this thread

1 Like

Seems to be some hope: OS 16.4 HomePod Introduces stream file failure · Issue #1941 · postlund/pyatv · GitHub

And a PR is already open: Fix for OS16.4 Stream file Timeout error by Ghawken · Pull Request #1942 · postlund/pyatv · GitHub

Crossing fingers…