After upgrade to z-wave js UI I don't see entities?

Hi, I have some z-wave I am using zwave-js, I upgrade it to z-wave js UI.
I install the add-on, copy the key S0,S1,S2 from the first add-on and past it to the z-wave js UI settings.
The new add-on see my USB dongle, also I see the switchs on the table but the security is disable and I don’t see any entites to restoring my automation.
When I open the option on the device table, under binary switch I can push the ON/OFF button the light is turn ON or OFF, the add-on working just wihtout any entities.
How can I restore my entities with same ID and name ?

You need to follow the instructions in the docs that explain how to switch. Sounds like you’ve haven’t re-configured the integration.

1 Like

Hi, Thanks for the information.
The step 1 to 3 I maked them before.
The step 4 is to reinstall again the add-on but I can only stop, restart or delete the add-on.
what does they mean by reinstalling it ?

Step 4 is re-installing the Integration, not add-on. Click “+ Add Integration” in Devices & Services and add the Z-Wave integration.

Ahh ok I make this ,
Now the integration ask me for URL, how to know what url I need to enter ?

When I did this a couple of days ago, the “integration” install provided a text box to enter the URL and it already had a default of ws://localhost:3000. This would likely work. However I noticed that the ZWavejs-UI Addon’s documentation page gives you different URL to use. In my case the URL it said to use was something that looked like ‘ws://addon_xxxxxxxx_zwavejs2mqtt:3000’ (where xxxxxxx is a series of alpha-numerics) and this was the one I went with (and it worked).

How to know which series of alpha-numerics to use?

Goto the Zwavejs-ui AddOn page (UI->Settings->Addons->Zwave JS UI) under “info” tab look for “hostname”. Or under “Documentation” tab on that page search for “ws://” and it should show the full URL to use.


I retry with a path like yours, ws://addon_xxxxxxxx_zwavejs2mqtt:3000
receive message that it’s already existing.
I just enable it again, it look like working, but on the table the security still with no entry symbol.
I add all same security key I haved in the old add-on, I uninstall it just know.
It’s normal?

The server address that worked for me was “ws://a0d7b954-zwavejs2mqtt:3000” without the “addon_” part.