After upgrading to 0.83.3 Google HOME TTS not working


#21

It is different thing when you ask google to turn on light or switch. This is from google assistant component.
for google TTS is text to speech.


#22

yes,
but googling my error this tread come out google tts…


#23

error log…

018-12-08 14:04:17 ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall switch.turn_on (c:05b6755a5ba448a2af40fc5b715ac160): entity_id=[‘switch.led_kitchen’]>
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 177, in handle_service
self._platforms.values(), func, call
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 250, in entity_service_call
permission=POLICY_CONTROL
homeassistant.exceptions.Unauthorized: Unauthorized


#24

Ok. So google assistant component need ssl which you don’t use. You definitely cannot control your devices from google assistant component. Unless you use cloud: which have to pay $US5 per month.

For google TTS. You don’t need ssl. So when you have fresh install of hassbian and home assistant. You can immediately use google tts.


To use Google Assistant, your Home Assistant configuration has to be externally accessible with a hostname and SSL certificate. If you haven’t already configured that, you should do so before continuing.


#25

it is very strange that my configuration was working very very good for a long time, i did all regular updates, but from version 0.83.2 on, google is not working…
a lot of people have same problems, some were solved updating to version 0.83.3, but for me not.
i did new clean installation and google still wont work…i did install python 3.6, still not working…
so, there was something wrong from version 0.83.2, for sure…


#26

Regarding Google TTS , Google Assistant Component.
Home Assistant try to make everything private which mean you can connect directly between your home assistant and google.

However, on Google part like google tts. This doesn’t need SSL to use.
On Google Assistant Component which you have to create project and link directly between your skill from Google to your Home Assistant server. This need SSL for both side security which google would accept if you have SSL.

So from now even you roll back to your Home Assistant version that used to work with Google Assistant, you won’t be able to handshake between your home assistant server and google assistant. Due to Google Assistant need SSL.


#27

o.k. thank you.

i set up hassbian, because my blackbean rm3 mini, was not working with google home.

Now this option is available, and i set up everything and is working…
Now i will start new raspberry project.

Thank you all for help and support…
The homeassistant is wonderful, fast and easy to use.

by
kikan