After upgrading to 0.83.3 Google HOME TTS not working


#1

hi,
today i did clean installation and google home still not working…
i did install python 3.6 and still same problem…
im using hassbian and virtual env…
description.xml on port 80 is working.
.
any news regarding this problem?
here is the output when i executing service .

thanks
by
kikan

018-12-03 21:59:07 ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall switch.turn_on (c:d07c0cb0b5d04df681929083295bcf64): entity_id=[‘switch.led_kitchen’]>
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 177, in handle_service
self._platforms.values(), func, call
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 250, in entity_service_call
permission=POLICY_CONTROL
homeassistant.exceptions.Unauthorized: Unauthorized


#2

What about 0.83.3?


#3

Yep, my TTS hasn’t been working now for the last few versions. I get a beep from the GH but no speech.

It works ok if I don’t use HTTPS.


#4

hi,
i have version: 0.83.3 and is not working…

thanks
by
kikan


#5

hi,
still no solution?

by
kikan


#6

try updating gTTS-token to 1.1.3


#7

Sorry, newbie here. How do we do this?

I’ve googled for the answer and found links such as this one which seems to say to go to this page and remove the red lines and add the green lines, but where do you go to do this and how do you do it?

Is it a text file or something?

Confusing jargon for us newbies - sorry for not being more knowledgeable.

EDIT:

I found this page, so I tried to do the steps at the top.

I didn’t know what “Activate Venv” was, so I googled it and got the following:

Install virtualenv via pip:

  1. $ pip install virtualenv .
  2. $ virtualenv --version.
  3. $ cd my_project_folder $ virtualenv my_project.
  4. $ virtualenv -p /usr/bin/python2.7 my_project.
  5. $ export VIRTUALENVWRAPPER_PYTHON=/usr/bin/python2.7.
  6. $ source my_project/bin/ activate .
  7. $ pip install requests.
  8. $ deactivate.

Pip command wasn’t working, so found this link on installing it.

I SSH’ed into my Pi, completed the first step:

curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py

but when I do the next step:

python get-pip.py

I get error messages about permissions and I believe my login is in the sudo group.

temp

So lost :frowning:


#8

sorry this worked for me - may not work for you etc etc

My HASS system is a python venv solution

homeassistant$  sudo -u homeassistant -H -s
    [sudo] password for walaj:
homeassistant$ source /srv/homeassistant/bin/activate
homeassistant$ pip3 list |grep -i tts
    gTTS-token                    1.1.3
homeassistant$ pip3 install --upgrade gTTS-token

I’m running 0.83.3

update - ok - you are running hassbian - sorry - not sure how that is handled


#9

OK - looking at https://www.home-assistant.io/docs/installation/hassbian/common-tasks/#update-home-assistant

try this

$ sudo systemctl stop [email protected]
$ sudo -u homeassistant -H -s
$ source /srv/homeassistant/bin/activate
$ pip3 install --upgrade gTTS-token
$ exit
$ sudo systemctl start [email protected]

#10

hi,
thanks for replay…

yes im on v 1.1.3 and is not working.

by
kikan


#11

If you have change gTTS-token to v1.1.3 and ha v0.83.3 . The google tts comes back to work. However, sometime you would find that you cannot click the 3 dots on media player and type to google tts directly. But via automation or service page is still work fine.

The 3 dots on media player cannot click to adjust volume and use google tts. This happen on non-touch screen for me.


#12

Hi,

no solution till now…
Google TTS NOT WORKING for weeks now,

by
kikan


#13

searching for solution all time…
messing with this i have new error…

Login attempt or request with invalid authentication from 3.80.200.46

7:54 AM components/http/ban.py (WARNING)

You need to use a bearer token to access /api/services/switch/turn_on from 3.80.200.46

7:54 AM components/http/auth.py (WARNING)

searching for this i found some info, but i don’t know how to …

im so stupid, because i know, that updating home assistant will cause some errors and will cause that for some days or weeks you will have to search etc…just to found what is wrong…

ah…

updating from version 0.83.1 to version 0.83.2, was no good idea…

by
kikan


#14

This hasn’t resolved the issue for me either.

I do find that the sound files are being created in the TTS folder on my Hassbian share if that helps with troubleshooting.


#15

If you can show your config part on http: and tts: then might be able to help. The tts google has been fix 0.83.3 so if you still cannot use then might be with the setting. Also what is the error log?


#16

hi,
thanks for replay.

this is in my config

.# Text to speech
tts:

  • platform: google
    language: ‘en-us’

http:
.# Uncomment this to add a password (recommended!)
api_password: xxxxxxxxx
.# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
.# base_url: example.duckdns.org:8123
Log
018-12-08 13:37:26 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don’t require it, remove the ‘api_password’ from your http config.
2018-12-08 13:37:46 WARNING (MainThread) [homeassistant.setup] Setup of recorder is taking over 10 seconds.
2018-12-08 13:37:46 WARNING (MainThread) [homeassistant.setup] Setup of frontend is taking over 10 seconds.
2018-12-08 13:39:09 ERROR (MainThread) [homeassistant.core] Error executing service <ServiceCall switch.turn_on (c:27d56b905b1f4146859c94df6ac0935f): entity_id=[‘switch.led_kitchen’]>
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 177, in handle_service
self._platforms.values(), func, call
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 250, in entity_service_call
permission=POLICY_CONTROL
homeassistant.exceptions.Unauthorized: Unauthorized


#17

ok.

tts:
  - platform: google
    language: 'en-us'

for http: did you use ssl or without? if use ssl on http section nothing about in tts

http:
  base_url: https://domain.duckdns.org:8123  <== put https in front if you have ssl or put http if you don't use ssl
 # api_password: yourpassword      <== uncomment #  it if you have use legacy password.
  ssl_certificate:/etc/letsencrypt/live/hass.example.com/fullchain.pem  <== change to where your file is if use ssl
  ssl_key: /etc/letsencrypt/live/hass.example.com/privkey.pem  <== change to where your file is if use ssl

Also when you posted your config please use </> on the menu so can see properly.

Also check if in your config directory have ban ip. if have maybe that the ip home assistant ban. so delete the ip-ban.yaml as well.


#18

im not using ssl


#19

Then use

http:
  base_url: http://domain.duckdns.org:8123  
  api_password: yourpassword

After change setting don’t forget to check config and restart ha.


#20

i put base_url
but same…

from outside my network i can open my homeassistant…
this is log now when im asking google to switch light on
018-12-08 13:49:52 WARNING (MainThread) [homeassistant.components.http] legacy_api_password support has been enabled. If you don’t require it, remove the ‘api_password’ from your http config.

Error executing service <ServiceCall switch.turn_on (c:602650f6f5aa4832b0a4948a22fead4f): entity_id=[‘switch.led_kitchen’]>
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/core.py”, line 1177, in _event_to_service_call
await service_handler.func(service_call)
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/entity_component.py”, line 177, in handle_service
self._platforms.values(), func, call
File “/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/service.py”, line 250, in entity_service_call
permission=POLICY_CONTROL
homeassistant.exceptions.Unauthorized: Unauthorized