Again: Negative values in Energy Dashboard

Hello together,
since I’ve changed my solar energy-measurement from Fritz!DECT to Hoymiles DTU-Lite (with HoyMiles Solar Gateway Addon) - I got negative values in my Energy Dashboard.

The data is comming from the sensor-entity “sensor.hoymiles_gateway_solarh_1234567_real_power_total_increasing”.
This is the only entity I can use in the Energy-Dashboard.
In the Hoymiles-Portal - I don’t have negative values.
I’m searching since days - but all the hints I can find - doesn’t solve the problem.
Would be great if I can find a solution here.
regards EU

Go to the home assistant history panel and take a screenshot of this sensor’s history for the same time period as shown in your energy dashboard above. Post it here. Don’t use the more-info pop-up. It hides spikes in the data.

This is solar generation, not power consumed.

Hello tom_I,
thank you for your feedback.
This is the only value I can select in the Energy Dashboard.
From my point of view, it should also be “sensor.hoymiles_gateway_solarh_1234567_real_power_measurement”.
But here I get the following error in the Energy Dashboard:
Last reset missing
The following entities have the status class “measurement”, but “last_reset” is missing:
Do I have to customize this entity?
Regards EU

Please do this for sensor.hoymiles_gateway_solarh_1234567_real_power_total_increasing so I can help you:

As for this:

That sounds suspiciously like a power sensor. It is not a power dashboard it is an energy dashboard. Two very different things.

Hello tom_I,
here are the two screenshots:

Your comment regarding Power is right but I have only these Energy values from Hoymiles:
Regards EU

And again Energy Dashboard:


Yeah that is not an energy sensor. At least not in a form the energy dashboard can use. It is reporting Wh for some short period of time. The correct energy sensor would look like this:

or this if there is a cloudy period in the middle of the day:

It is stll always increasing throughout the day as you generate energy.

Try feeding your sensor to a utility meter:

Make sure to use the option delta_values: true

Then feed the sensor that the utility meter creates to the energy dashboard. You don’t need to set the cycle option but daily would give you something useful if you want. The energy dashboard can deal correctly with the reset at midnight.

Oh man - I’m so stupid…
Sorry. I’ve now used the sensor.hoymiles_gateway_solarh_1234567_today_eq_wh - and it looks good.

Apparently the Energy Dashboard converts this correctly. This is where I was misled.
Thanks for your support!

1 Like