AIO now using python 3.5 breaks components set to 3.4

AIO is very much broken at the moment…

Mainly because of the change from python 3.4 to 3.5 - a lot of components are still dependant on 3.4 and unfortunately these are the first components I have had to deal with home assistant, so to say my dealings with the service have been difficult at best.

only tried open z wave, hdmi cec, however I am guessing python is pretty critical and a broken path (symlinks are broken) means all references that require it (that haven’t been updated to 3.5) will be broken…

Not sure where to go from here.

HA will phase out support for Python 3.4 from 2018:
So to change AIO to 3.5 is just a start


Do you know if there is a guide somewhere for those still on 3.4 to guide, step by step how to install 3.5 (or higher) and upgrade / re-configure so that HA will use the new version?

(I had a quick search on the main HA site and could not find something)

Works fine here…

Interesting, it worked fine for me on Python 3.4 this morning, and I’m not seeing any changes pushed since then (indeed, the last change was back in May).

Can you share your error messages if you’re having problems?

Otherwise, yes, all of us currently on Raspbian Jessie will need to either upgrade/rebuild with Stretch, or compile and install Python 3.5 manually before support is dropped. Hopefully that will be after the issues with Mosquitto and libcec are fixed :wink:

The issues I get are symlink related from the 3.5 reference, the install itself crashes (thanks to libcec symlinks) and the symlinks break the modules I have tried (libcec, openzwave, and a couple others)…

tbh I don’t doubt that it’s the component authors responsibility to update their respective components, however I wonder when is the right time for HA to move over… or at least support the errors… I mean we can check for python versions when creating the symlink such as:

if (<python3.4Path> exists)
write symlinks for 3.4
write symlinks for 3.5

of course that is a very ignorant statement as it’s never that simple - however a bit of support would go a long way for noobies such as myself who will only get frustrated trying to constantly patch something that shouldn’t need patching at install